Closed Bug 1174601 Opened 5 years ago Closed 5 years ago

Copy nsDragAndDrop.js from toolkit to SeaMonkey because it will be removed in bug 1162050

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.39 fixed)

RESOLVED FIXED
seamonkey2.39
Tracking Status
seamonkey2.39 --- fixed

People

(Reporter: ewong, Assigned: philip.chee)

References

Details

Attachments

(1 file)

From https://bugzilla.mozilla.org/show_bug.cgi?id=1162050#c0,

nsDragAndDrop.js could well be removed from toolkit.  Since changing TB/SM/etc
to use the new drag and drop API is 'involved' (afaiu), it would be a good
stepping stone (and to give time to whoever wants to migrate the projects
to use the DnD API), Neil Deakin suggested we copy the nsDragAndDrop.js to
some common place in c-c (i.e. mailnews/base/util, or Neil Parkway suggested
mailnews/base/content if TB wants to keep nsDragAndDrop.js).
:rkent, what should be done?

Is TB using the new DnD api or still using the nsDragAndDrop.js file?
Flags: needinfo?(rkent)
Ah. never mind.  Apparently this was done with bug 1171979. 

Sorry for the bug spam.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(rkent)
Resolution: --- → DUPLICATE
Duplicate of bug: 1171979
Geez. Reading comprehension fail. 

In bug 1171979, nsDragAndDrop.js was placed in mail/base/content.

Can we put it in mailnews/base/content, so that there's no need for duplication
of files within c-c?
Status: RESOLVED → REOPENED
Flags: needinfo?(rkent)
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Is it worth it to bring over the blame/history as well? I could do that if needed.
Thunderbird still needs it AFAIK. The reason I put it under mail/ in bug 1171979 is that I hope the file will be very short-lived...
Flags: needinfo?(rkent)
(In reply to Philip Chee from comment #4)
> Is it worth it to bring over the blame/history as well?

Probably not, if it's deprecated and due to be removed anyway.

(In reply to Edmund Wong from comment #3)
> In bug 1171979, nsDragAndDrop.js was placed in mail/base/content.
> 
> Can we put it in mailnews/base/content, so that there's no need for
> duplication of files within c-c?

Failing that, you can hg copy Thunderbird's new copy into suite.

I don't like mkmelin's approach of building nsDragAndDrop.js into toolkit.jar; I'd prefer building it into messenger.jar and using a chrome override.
Product: MailNews Core → SeaMonkey
Summary: Copy nsDragAndDrop.js from toolkit to MailNews due to bug 1162050 → Copy nsDragAndDrop.js from toolkit to SeaMonkey because it will be removed in bug 1162050
Version: unspecified → Trunk
(In reply to neil@parkwaycc.co.uk from comment #6)
> (In reply to Philip Chee from comment #4)
>> Is it worth it to bring over the blame/history as well?
> Probably not, if it's deprecated and due to be removed anyway.
I experimented with a transplant from mozilla-central 23 changesets incoming.

> Failing that, you can hg copy Thunderbird's new copy into suite.
Thunderbird patch hasn't landed yet so here is just a new file with no history.

> I don't like mkmelin's approach of building nsDragAndDrop.js into
> toolkit.jar; I'd prefer building it into messenger.jar and using a chrome
> override.
Done.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8625067 - Flags: review?(neil)
Blocks: 1171980
Attachment #8625067 - Flags: review?(neil) → review+
http://hg.mozilla.org/comm-central/rev/317ca58dbe02
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.39
You need to log in before you can comment on or make changes to this bug.