If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TimeoutException in waiting for visible autocomplete suggestions in test_suggest_bookmarks_py (TestStarInAutocomplete)

RESOLVED FIXED in Firefox 41

Status

Testing
Firefox UI Tests
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

41 Branch
mozilla41
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed)

Details

(Whiteboard: [test-failure])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Since yesterday we have another regression in our autocomplete tests which is about the check for shown visible results. We are timing out here.

Traceback (most recent call last):
File "/Users/Mozauto/jenkins/workspace/mozilla-central_functional/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 296, in run
testMethod()
File "/Users/Mozauto/jenkins/workspace/mozilla-central_functional/venv/lib/python2.7/site-packages/firefox_ui_harness/decorators.py", line 23, in wrapper
return target(self, *args, **kwargs)
File "/Users/Mozauto/jenkins/workspace/mozilla-central_functional/venv/lib/python2.7/site-packages/firefox_ui_tests/functional/locationbar/test_suggest_bookmarks.py", line 79, in test_star_in_autocomplete
self.wait_for_condition(lambda mn: len(autocomplete_results.visible_results) == 2)
File "/Users/Mozauto/jenkins/workspace/mozilla-central_functional/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 677, in wait_for_condition
    raise TimeoutException("wait_for_condition timed out")

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7ee8e13145a&tochange=c223b8844264
(Assignee)

Comment 1

2 years ago
This is clearly a regression for us caused by the changes on bug 959594. So we clearly need the fix from bug 1170148 Barbara is working on.

I will temporarily skip this test.
Blocks: 959594
Depends on: 1170148
Keywords: regressionwindow-wanted
(Assignee)

Updated

2 years ago
Summary: TimeoutException in waiting for visible autocomplete suggestins in test_suggest_bookmarks_py (TestStarInAutocomplete) → TimeoutException in waiting for visible autocomplete suggestions in test_suggest_bookmarks_py (TestStarInAutocomplete)
(Assignee)

Updated

2 years ago
status-firefox41: affected → disabled
Whiteboard: [test-failure] → [test-failure][disabled]
(Assignee)

Comment 2

2 years ago
Disabled the test via:
https://github.com/mozilla/firefox-ui-tests/commit/d8fd64110f335f0ca1ecce468aaab5715b59a4a5
(Assignee)

Comment 3

2 years ago
Marco or Drew, while trying to fix this test failure I was wondering what happens with the old preference for enabling and disabling specific items for suggestions:

browser.urlbar.default.behavior vs. browser.urlbar.suggest.searches

Is the first pref not used anymore in favor of the new browser.urlbar.suggest.* preferences?
Flags: needinfo?(mak77)
Flags: needinfo?(adw)
(Assignee)

Comment 4

2 years ago
Created attachment 8624646 [details] [review]
github_pull_request.txt

Uploading for review already, but will wait with the landing until I got a reply from Drew or Marco.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Attachment #8624646 - Flags: review?(dave.hunt)

Updated

2 years ago
Attachment #8624646 - Flags: review?(dave.hunt) → review+
Right, browser.urlbar.suggest.* replaced browser.urlbar.default.behavior in bug 530209, so please use them instead.  http://hg.mozilla.org/mozilla-central/rev/af22db534027
Flags: needinfo?(mak77)
Flags: needinfo?(adw)
(Assignee)

Comment 6

2 years ago
Ok, thanks Drew! Interesting that this already landed for 36. Looks like our Mozmill tests which were using this old pref didn't fail so far because of the removal. Anyway those are plainly dead, and for the new Firefox UI tests this is the first test which actually makes use of that preference. So we are good in getting only this test updated and landed.
(Assignee)

Comment 7

2 years ago
https://github.com/mozilla/firefox-ui-tests/commit/9afb134f7d225117915bb5d5bf4d47be228b14f0
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox41: disabled → fixed
Resolution: --- → FIXED
Whiteboard: [test-failure][disabled] → [test-failure]
Target Milestone: --- → Firefox 41
Product: Mozilla QA → Testing
You need to log in before you can comment on or make changes to this bug.