[Flame][E-mail]When user tries to record a video for adding as an attachment in Email, the video recording is not smooth in 319MB config.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: hedan, Assigned: sotaro)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8622414 [details]
v3.0.3gp

[1.Description]:
[Flame v3.0][E-mail]The video recording is not smooth, and sometimes it cannot stop recording when we tap the shutter icon again.

Occur Time:17:16
Attachment: logcat1716.txt & v3.0.3gp

[2.Testing Steps]: 
Precondition: You have signed in a Email account.
1.Launch Email app.
2.Tap the icon at top right corner-> tap the clip icon->choose camera
3.Change to Video camera mode,and start to record.

[3.Expected Result]: 
3.The video recording should be normal.

[4.Actual Result]: 
3.The video recording is not smooth,and sometimes user cannot stop recording when it retards.

[5.Reproduction build]: 
Device: Flame 3.0(319Mb)  (affected)
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.044513
Firmware Date          Sun Jun 14 04:45:25 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 (Unaffected)
Build ID               20150614002504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.040237
Firmware Date          Sun Jun 14 04:02:49 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 (Unaffected)
Build ID               20150614002504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150614.042607
Firmware Date          Sun Jun 14 04:26:25 EDT 2015
Bootloader             HHZ12d

Device: Nexus5 3.0 (Unaffected)
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150614.044149
Firmware Date          Sun Jun 14 04:42:08 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
occasionally Recurrence,3/5

[7.TCID]: 
Free Test

[8.Note]It will not appear at Camera app.
(Reporter)

Comment 1

3 years ago
Created attachment 8622415 [details]
logcat1716.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Moving to the video app for further triaging/moving or analysis.  If the video gets choppy I'd expect this is some combination of system video related issue, being triggered from an activity (possibly with the email app's DOM impacting repaints), or a memory scarcity problem (especially if this is 319M).
Component: Gaia::E-Mail → Gaia::Video
Adding qawanted to test this scenario in 512 or 1024MB configuration
Keywords: qawanted
(Reporter)

Comment 4

3 years ago
Created attachment 8637707 [details]
Flame_master(512MB).3gp

Hi No-Jun, 
This bug can't be repro on 512/1024MB mem in both email app and video app (but can be repro on 319MB mem) on latest Flame master. So it seems a memory problem. 

Results:
The video recording is normal on 512/1024MB mem in both email app and video app.

See attachment: Flame_master(512MB).3gp
Reproduce rate: 0/10

Device: Flame master(unaffected)                                            
Build ID               20150722160203
Gaia Revision          f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gaia Date              2015-07-22 18:44:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8650fe82f1cd
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150722.194012
Firmware Date          Wed Jul 22 19:40:25 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(npark)
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
Thanks, updated title to reflect the latest findings.  Hema, are performance related bugs in 319MB config qualifies as a blocker?
Flags: needinfo?(npark) → needinfo?(hkoka)
Summary: [Flame][E-mail]When user tries to record a video for adding as an attachment in Email, the video recording is not smooth. → [Flame][E-mail]When user tries to record a video for adding as an attachment in Email, the video recording is not smooth in 319MB config.

Comment 6

3 years ago
(In reply to No-Jun Park [:njpark] from comment #5)
> Thanks, updated title to reflect the latest findings.  Hema, are performance
> related bugs in 319MB config qualifies as a blocker?

yes, marking this a blocker. Russ, can you check this and route if it is core media issue. 

Thanks
hema
Flags: needinfo?(hkoka) → needinfo?(rnicoletti)
I have confirmed that the issue can be reproduced with a 319MB configuration and cannot be reproduced with a 512MB configuration. Some other observations from my testing:

* The issue does not reproduce when using the SMS app to record a video. 
* When recording a video from the email app, the video usually becomes choppy after approximately 14 or 15 seconds or recording.
* The SMS app stops the video recording when the size of the video exceeds the maximum attachment size, which is usually after about 13 seconds.

My guess is the reason the video is getting choppy after a 14 or so seconds of recording is that the available memory, which is already constrained by the email app activity, is being further constrained by the video recording; and we don't see this with the SMS app because it is stopping the recording before the memory issue is reached. Continuing along this line of thinking is that this is a gecko issue.

NI for Sotaro to comment on my analysis.
Flags: needinfo?(rnicoletti) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 8

3 years ago
On master, memory usage seems to be increased. I am going to take a look.
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 9

3 years ago
bug 1148715 confused me about understanding the symptom of the bug.
See Also: → bug 1148715
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.