my.netscape.com refreshs forever

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Itamar, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20020114], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7+) Gecko/20011230
BuildID:    2001 12 30 08

This started happening just a few builds before 0.9.7.
I go into http://my.netscape.com and the URL changes into
http://my.netscape.com/index2.psp?cp=myfresh and reloads forever.
This never used to happen but I'm not sure if this is a change that was made in
mozilla or a change made in my.netscape web site.
Any way it never happens in IE 5 and never used to happen.
This happens somtimes but most of the times - in other times the page loads
correctly.

Reproducible: Sometimes
Steps to Reproduce:
1.open http://my.netscape.com
2.if the page opens ok try again in a few minuets

Actual Results:  page doesn't load correctly - see attachment

Expected Results:  page should load properly
(Reporter)

Comment 1

16 years ago
Created attachment 63111 [details]
my.netscape.com - bad load

Comment 2

16 years ago
Reporter, I can't reproduce with the Jan 2rd build (2002-01-02-03) under Windows
ME. Can you try with a nightly build ? 

http://ftp.mozilla.org/pub/mozilla/nightly/latest/
(Reporter)

Comment 3

16 years ago
Hi,
Downloaded the lastes a few hours ago.
At first I couldn't reproduce it.
But All I had to do is wait a few hours and try again.
I still get the same problem.
The strange thing is that using IE I can never see in the URL bar a redirection
to http://my.netscape.com/index2.psp?cp=myfresh
Any way still happens with:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7+) Gecko/20020103
Chris Petersen -> from your comment I understand that u managed to reproduce it
atlest once before - right?

Comment 4

16 years ago
No, I haven't been able to reproduce it yet.
(Reporter)

Comment 5

16 years ago
Just installed 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7+) Gecko/20020106
on a new computer at work - Win 2000 as you can see.
The problem sprung up on the first try to open http://my.netscape.com
I have the following services on the page:
Personal Finance,
Top Story,
My Services,
News,
What's New,
Weather,
Movies,
and Shopping
Hope this helps - if you can't reproduce it I'll try and removing tabs from the
page. Maybe its a specific tab the causes the problem.
(Reporter)

Comment 6

16 years ago
OK this is what I did,
Removed all the tabs from my.netscape personal page.
removed all cookies from mozilla that relate to netscape.
when I opened http://my.netscape.com - it opened up the general page correctly.
I clicked login and and entered the username and password.
the mozilla was directed to http://my.netscape.com/index2.psp
and after a few seconds to http://my.netscape.com/index2.psp?cp=myfresh
and the problem is still there.

Comment 7

16 years ago
using the trunk build from 20020114 on W2K, I do not see the refresh happening.
If you see the refresh happening again, can you enter these into the location
bar and tell me what the values are in the alert box:
javascript:alert(ua)
javascript:alert(redirectPage)

that will help in being able to debug what you are experiencing, for now marking
as wfm

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Whiteboard: [bae:20020114]
(Reporter)

Comment 8

16 years ago
ok - this still happens
javascript:alert(ua) == Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 
rv:0.9.7+) Gecko/20020114
and javascript:alert(redirectPage) == false
I pasted those things on when the page refreshes forever on:
http://my.netscape.com/index2.psp?cp=myfresh
(Reporter)

Comment 9

16 years ago
Created attachment 64990 [details]
The page source
(Reporter)

Comment 10

16 years ago
not sure if it is related but search the page source for the word myfresh and
you'll find the following lines:
<META HTTP-EQUIV='Content-Type' CONTENT='text/html;charset=iso-8859-1'>
<TITLE>My Netscape</TITLE>
<META HTTP-EQUIV="Refresh" CONTENT="28800;URL=/index2.psp?cp=myfresh">

On the other hand when I opened the attachment with IE it automaticly opened the
my.netscape.com website - I guess IE bug that it doens't "belive" the content type.

Comment 11

16 years ago
*** Bug 125594 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
From bug 125594:

When loading my.netscape.com, it loads perfect when not logged into mynetscape.
However after logging in, the site constantly refreshes as quickly as it loads.

Comment 13

16 years ago
The problem might be in the cookie that is stored on the server and/or with the
data that the server is serving based on the cookie value.

Here's what I did to clear my refresh problem. Deleted all cookies related to
netscape.com. Then I created a new login on my.netscape.com and signed in.
I haven't completely finished setting up my layout as to what I had before,
however I haven't had it refresh forever yet either.
I will try a few hours from now as it is apparent that several others that are
experiencing this have cleared it only to have it reappear a few hours later.

Comment 14

16 years ago
I configured my netscape layout exactly as I had it with my other mynetscape
acct. It still works fine. However after leaving it sit on that page for a few
hours, the auto refresh worked a couple times but somewhere in those few hours
(i was away from PC after an hour) it got caught in the dreaded loop. All I had
to do was re-enter my.netscape.com in location bar and all was fine again.
It's obvious there is an anamoly somewhere that mozilla doesn't like, other
browsers seem happy with it (communicator, ns6, IEx), I also haven't seen this
loop in *nix builds. I wonder if it's a coexisence thing, because on my win98
machine I have communicator 4.78, and at one time I had NS6. I've had mozilla
installed all along.....
You need to log in before you can comment on or make changes to this bug.