Firefox becomes unresponsive when launched directly from a file

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Wild Willy Kredentser, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

With no Firefox task currently running, from Windows Explorer select an HTML file and hit Enter.


Actual results:

After scrolling the web page, Firefox becomes "unresponsive" which is the word Windows puts in the window title bar when it then makes the window inaccessible to further use.  I am able to kill FF from the Task Manager, which appears to be the only way out.  When it relaunches, it tries to resume the same session.  I quickly close all the windows before scrolling any of them in order to avoid a recurrence of the problem.


Expected results:

It shouldn't have locked up, obviously.  If I launch FF from the Start Menu so that a firefox.exe entry already exists in Task Manager, even if my only open FF window is just the Library window, then I can hit Enter on the HTML file in Windows Explorer and the problem does not occur.
(Reporter)

Comment 1

3 years ago
This bug is intermittent.  I have encountered it a number of times over the past 3 or 4 weeks.  But I've tried several times just now to reproduce it & I have to admit I was unable to recreate it.  But honest, it was happening.  I didn't imagine it.  It was happening practically every time.  Now it's fine.  Go figure.  Maybe FF figured out I was tattling on him & now he's behaving.  I don't know . . .
please post a log from about:support
It's possible some of your add-ons is causing this strange behavior, maybe you could try in a clean profile? https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

And if that helps you might try resetting your profile:
https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Updated

3 years ago
Flags: needinfo?(wildwilly)
(Reporter)

Comment 3

3 years ago
Created attachment 8623028 [details]
AboutSupport_1.txt

The "copy text to clipboard" version of about:support
Flags: needinfo?(wildwilly)
(Reporter)

Comment 4

3 years ago
Created attachment 8623030 [details]
AboutSupport_2.txt

The "copy raw data to clipboard" version of about:support
(Reporter)

Comment 5

3 years ago
I swear this product is self-aware.  Since I posted this report I have been utterly unable to cause the problem again.  And I've tried maybe 15-20 times.  To my knowledge I have done nothing to alter my system.  I promise I'll post again if it ever happens again but for now, I think maybe I'll just tuck my tail between my legs and slink back into my burrow.

Comment 6

3 years ago
Besides that, I think you should update your ATI Radeon HD 3400 drivers to the latest version, 13.9 (15/10/2013):
http://www2.ati.com/drivers/legacy/13-9-legacy_vista_win7_64_dd_ccc_whql.exe

It could fix some perf issues.
(Reporter)

Comment 7

3 years ago
Thanks for that.  I suppose I should have done that on my own a long time ago.  However, this problem seems to have gone away the moment I reported it.  And I am not suffering any performance issues.  Nonetheless, I have downloaded & installed the newest drivers for my video adapter.  Which aren't all that new, are they?  I'm not sure it's made any difference.  Then again, I haven't rebooted yet.  The installer did not tell me I had to, which rather surprises me.  But I will make a point of rebooting later, when it's more convenient for me.  Assume no news is good news, which is to say, if I remain silent here from this point forward, it means everything is fine.  Unless, of course, somebody posts something that requires some action on my part.

I do note that, buried in the new software I seem to have acquired with this new driver, there is something that appears to allow me to define multiple desktops.  That sounds like a fun toy I may play around with.  And anything more about that is so far off this topic I won't mention it again.

Comment 8

3 years ago
It sounds like this has gone away ("works for me"). If you figure out steps to make this reproduce reliably and/or have more clues about something Firefox is doing that we need to address, please feel free to reopen this report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.