Cannot restore crashed tabs

RESOLVED DUPLICATE of bug 1166351

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1166351
3 years ago
3 years ago

People

(Reporter: mossop, Assigned: mconley)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10s-)

Details

(Reporter)

Description

3 years ago
My content process crashed so I clicked to restore all tabs ... and nothing happened.

This error shows up in the console when I click the button:

TypeError: aBrowser.webProgress is undefined

I managed to restore the main tab but now clicking on my pinned tabs doesn't select them.
(Reporter)

Comment 1

3 years ago
My pinned tabs did restore and work after a restart.
This loss of aBrowser.webProgress sounds an awful lot like what I'm investigating in bug 1166351...

I've been attempting to reproduce with no success. Perhaps the pinned tabs are related.
Assignee: nobody → mconley
tracking-e10s: ? → m7+
I'm tempted to dupe this to bug 1166351, but the details are so scant[1] here that I'm only 90% sure they're the same thing.

I'll leave this bug undupe'd for now, but assuming these two are in fact related, I'll be doing most of the work in bug 1166351.

[1]: Not a criticism of Mossop's description - just that the way the bug presents doesn't make it obvious what's going on, really.
Hey Mossop - can you give me a sense of how many tabs and windows you had open at the time of the crash, and how much load your machine was under (ie, were you doing a build in the background?)
Flags: needinfo?(dtownsend)
(Reporter)

Comment 5

3 years ago
I had maybe 4-5 pinned tabs and 1 normal tabs. I don't recall if I was compiling in the background, based on the time I filed it probably not.
Flags: needinfo?(dtownsend)

Updated

3 years ago
Depends on: 1166351
I highly suspect this is bug 1166351, which I'm duping this to now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1166351
You need to log in before you can comment on or make changes to this bug.