The default bug view has changed. See this FAQ.

lightning calendar didn't get installed when upgrading to thunderbird 38.0.1

RESOLVED FIXED

Status

Thunderbird
Build Config
--
blocker
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Remy Mentasti, Assigned: Fallen)

Tracking

(Blocks: 1 bug)

38 Branch
x86
Windows Vista
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird_esr3839+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
Build ID: 20150321194901

Steps to reproduce:

I've update from Thunderbord 37.X (not sure what version was) and I've found that Calendar was not here.

Even if I create a new profile, Lighting is missing.

Step to reproduce:
1)Update a previous version from Help --> About Thunderbird

After I've downloaded the full setup and, if I create a New profile, Calendar is here, but not in previous existing profiles.


Actual results:

No calendar is shown, and Lighting is not shown in addons list


Expected results:

Lighting should be shown in addons list and Calendar Menu is shown.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows Vista
Hardware: Unspecified → x86
Summary: Thunderbird 38.0.1 calendar not found in profiles → Thunderbird 38.0.1 calendar not found in addons

Comment 1

2 years ago
Could this be something Windows Vista specific?
How was ligthing originally installed? By you or somehow differently by an administrator?
Keywords: regression
Each profile has it's own list of addons. So Installing calendar in the new profile would not affect the old profile.

In the old profile, do you get the new calendar if you go to tools | addons and check for updates?

Comment 3

2 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Thunderbird/38.0.1

I use a Mac. I manually updated Thunderbird 31.7.0 (from About Thunderbird) and I can not find Lighting in my addons.
I never used Lightning in previous versions of Thunderbird.

If I go to tools | addons and I check for updates I do not get the new calendar.

Comment 4

2 years ago
Sorry, maybe I've missed to say that, in version 37.X, I've not installed Lighting.

In version 38.0.1 release notes https://www.mozilla.org/en-US/thunderbird/38.0.1/releasenotes/ ,
I found that Lighting calendar addon was shipped with Thunderbird and enable with an opt-out dialog.

No opt-opt dialog was shown and Lighting is missing in addons list.

Comment 5

2 years ago
I've been getting a number of reports of this, like in comments to my blog post. It would be good to understand the exact circumstances that cause the Lightning addition to fail, but it is not a particularly serious issue since the obvious workaround is to just install it normally. I would also not call this a regression, it is the failure of a new feature.

Comment 6

2 years ago
Thx for the clarification! Updating summary.
Keywords: regression
Summary: Thunderbird 38.0.1 calendar not found in addons → lightning calendar didn't get installed when upgrading to thunderbird 38.0.1

Updated

2 years ago
Duplicate of this bug: 1175981

Comment 8

2 years ago
This is weird - I don't have an distribution/extensions folder in the app directory on my Win7 machine which received an update from 31.0.7 using the about dialog. Without that folders, it's obvious that Lightning cannot be installed, because it's simply not shipped. I didn't noticed that since I had Lightning installed anyway.

If I install the full version from the website instead, the folder is there, so eventually something is wrong with the mar updates.
(Assignee)

Comment 9

2 years ago
Confirmed by inspection. The update packager does some special casing for distribution extensions, to only add the files if the parent directory exists.

http://mxr.mozilla.org/comm-central/source/mozilla/tools/update-packaging/make_incremental_updates.py#47

This is confirmed in the following log file, search for "Adding file add instructions to update manifests".

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/candidates/38.0.1-candidates/build1/logs/release-comm-esr38-linux_build-bm72-build1-build0.txt.gz

The "add-if" instruction will only add the Lightning files if distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} exists in the installation, which is of course not the case for 31.x.

AFAICT from the log, the add-if is used for both complete and partial updates, although bug 841094 suggests it should only be the case for partials. If that were the case we could just disable partials for 31 -> 38.

Robert, do you think you could help us out here? I've read through bug 841094 and bug 299021, but I don't quite understand why distribution extensions need to be installed with add-if. IIUC then distribution extensions are always pre-packaged anyway. As a result, they will always be installed into the profile, so they are not optional extensions and don't need to be conditionally added.

tl;dr; should distribution extensions be packaged with "add-if" at all? And if yes, should that also be the case for complete updates? If there is a good reason to do this, I would appreciate if a patch were accepted to make that behavior optional, e.g. with a flag. I'm happy to spin up a patch if I know what needs to be done.
Severity: normal → blocker
Status: UNCONFIRMED → NEW
tracking-thunderbird38: --- → ?
Component: Untriaged → Build Config
Ever confirmed: true
Flags: needinfo?(robert.strong.bugs)
(Assignee)

Comment 10

2 years ago
If we can't get this changed on mozilla-esr38, we can of course hack it into THUNDERBIRD_38_VERBRANCH. Once users have distribution/extensions/{e...} in their tree, subsequent updates will get the files installed.
There are added with add-if so the update doesn't fail if the files are removed.

To work around this you will need to create one-off mar files by changing the code that creates the mar files to use add instructions and then creating the mar files. I wouldn't have a problem with a flag being added but you will need to run this by and get review from releng since even though I have been the main person updating this code as of late it is actually releng code.
Flags: needinfo?(robert.strong.bugs)
(Assignee)

Comment 12

2 years ago
Robert, thanks for the quick answer! Why would the files be removed from distribution/extensions? Do you mean if they are removed during an update and then another update is applied that attempts to add them again? In what way would the update fail?

Marking myself needinfo to create the one-off patch for now. I'll have to check with drivers to see if we need to keep this around for all of tb38, or if updates will eventually go 31.7.0 -> 38.0.2 -> 38.latest.
Flags: needinfo?(robert.strong.bugs)
Flags: needinfo?(philipp)
In the past they have been removed via removed-files, then re-added, and then removed again. Some people also removed them. If they are present in two consecutive updates then patching will fail.
Flags: needinfo?(robert.strong.bugs)
Also, the people that remove it are surprised when it re-appears if add instructions are used.

To get around this you can do one-off mar files that adds these files and require people to update to that version.

Comment 15

2 years ago
The mar for the complete update is affected as well - see comment #3 of bug 1176665

Updated

2 years ago
tracking-thunderbird38: ? → ---
tracking-thunderbird_esr38: --- → +

Comment 16

2 years ago
Philipp, I did some update tests with complete and partial updates.

Even with a manually created distribution/extensions/ folder (and an addon in it to make sure it gets not removed) in the application folder of the TB version to update, no Lightning 4.0 is present therein after updating to TB 38.
(Assignee)

Updated

2 years ago
Blocks: 1177028
(Assignee)

Comment 17

2 years ago
Created attachment 8625709 [details] [diff] [review]
Fix - v1

This should take care, we need to push this to THUNDERBIRD_38_VERBRANCH on mozilla-esr38.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Flags: needinfo?(philipp)
Attachment #8625709 - Flags: review?(Pidgeot18)

Comment 18

2 years ago
Also on OS X

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Thunderbird/38.0.1

Build-ID: 20150608103712
(Reporter)

Comment 19

2 years ago
I've updated from Thundebird 37 on Windows XP and the problem came out.

I think platform information should be set to All All

Updated

2 years ago
tracking-thunderbird_esr38: + → 39+
Comment on attachment 8625709 [details] [diff] [review]
Fix - v1

This should be fine but definitely test partial and complete mars before releasing. Also keep in mind my previous comments in this bug so you don't shoot yourself in the foot with an update after this one.
Attachment #8625709 - Flags: feedback+
(Assignee)

Comment 21

2 years ago
Comment on attachment 8625709 [details] [diff] [review]
Fix - v1

Thanks for the feedback. We are going to push this patch as is now, I've received approval from rkent via tb-drivers email. We'll make sure to test the mar update before releasing and make sure to not install/uninstall it via updates as described.
Attachment #8625709 - Flags: review?(Pidgeot18)
(Assignee)

Comment 22

2 years ago
Pushed this despite CLOSED TREE, as it won't affect Firefox.

https://hg.mozilla.org/releases/mozilla-esr38/rev/6f7c23a646f5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
status-thunderbird_esr38: --- → fixed
Blocks: 1215828
You need to log in before you can comment on or make changes to this bug.