<select> dropdown arrow is horizontally misaligned when RTL dilection on Windows7 Classic

VERIFIED FIXED in Firefox 41

Status

()

Core
Layout: Form Controls
--
minor
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: jfkthame)

Tracking

({regression, rtl})

41 Branch
mozilla42
Unspecified
Windows 7
regression, rtl
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41+ verified, firefox42 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8622985 [details]
select_rtl.html

[Tracking Requested - why for this release]: Regression

This is regression since Nightly41.0a1.
This happens with/without e10s.

Steps To Reproduce:
1. Open attached

Actual Results:
<select> dropdown arrow is horizontally misaligned 
See screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8622986 [details]
screenshot
(Reporter)

Updated

3 years ago
Keywords: rtl
(Reporter)

Updated

3 years ago
Severity: normal → minor
(Reporter)

Comment 2

3 years ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3324527b41cc&tochange=c53efb981810

Triggered by: Bug 1113206
Blocks: 1113206

Comment 3

3 years ago
Matt, could you please let us know if this is by design or a UI bug? Is this something we want to fix in 41?
Flags: needinfo?(matt.woodrow)

Comment 4

3 years ago
Adding a tracking flag for FF41. Matt, if this is by design, please let us know.
tracking-firefox41: ? → +
I have no idea, this seems more like a question for Simon.
Flags: needinfo?(matt.woodrow) → needinfo?(smontagu)
No, this isn't by design. 

The bug is presumably in setting buttonRect.x inside nsComboboxControlFrame::Reflow, where I removed the special-casing for RTL.

Unfortunately the bug isn't reproducible on OSX and I won't have access to a developing environment on Windows in the next two months. Jonathan, can you take this on?
Flags: needinfo?(smontagu) → needinfo?(jfkthame)
(Assignee)

Comment 7

3 years ago
I'll try to take a look soon.
Assignee: nobody → jfkthame
Flags: needinfo?(jfkthame)

Comment 8

3 years ago
This also happens in https://dl.dropboxusercontent.com/u/95157096/85f61cf7/j3rap7updi.html.
(Assignee)

Comment 9

3 years ago
Created attachment 8631627 [details] [diff] [review]
Include borderPadding in the combobox's containerWidth, so that dropdown arrow is positioned correctly in RTL

I think this one is simple: we're supposed to include the borderPadding with the computedWidth as containerWidth, just like we do in lots of other places. (Bug 1177614 will provide a utility function to replace this, but for now let's try the fix here.)
Attachment #8631627 - Flags: review?(smontagu)
(Assignee)

Comment 10

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ed12d4950457
Comment on attachment 8631627 [details] [diff] [review]
Include borderPadding in the combobox's containerWidth, so that dropdown arrow is positioned correctly in RTL

Review of attachment 8631627 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense
Attachment #8631627 - Flags: review?(smontagu) → review+
(Assignee)

Comment 12

3 years ago
This appears to fix the problem for me on Win8. Alice0775, if you could confirm it also resolves the issue for you, that would be great -- thanks. Tryserver build is currently in progress (comment 10).
(Reporter)

Comment 13

3 years ago
Confirmed.
The try-server build fixes the problem on Windows7 Classic.
https://hg.mozilla.org/try/rev/e275e33d0e11
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150709090503
(Assignee)

Comment 14

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/aef99fde8ffe
(Assignee)

Comment 15

3 years ago
Comment on attachment 8631627 [details] [diff] [review]
Include borderPadding in the combobox's containerWidth, so that dropdown arrow is positioned correctly in RTL

Approval Request Comment
[Feature/regressing bug #]: 1113206
[User impact if declined]: minor visual glitch in RTL comboboxes on some platforms/themes
[Describe test coverage new/current, TreeHerder]: tested locally, confirmed by reporter using tryserver build
[Risks and why]: minimal risk: minor adjustment to metrics within combobox layout, no wider effects
[String/UUID change made/needed]: none
Attachment #8631627 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/aef99fde8ffe
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42

Comment 17

3 years ago
Comment on attachment 8631627 [details] [diff] [review]
Include borderPadding in the combobox's containerWidth, so that dropdown arrow is positioned correctly in RTL

Approving for uplift to Aurora because minimal risk, changes are only made to combobox container.
Attachment #8631627 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/d1d1000403e5
status-firefox41: affected → fixed

Comment 19

3 years ago
Please see the screenshot from https://bugzilla.mozilla.org/show_bug.cgi?id=1177660#c8 ... because I can also reproduce the issue with the misaligned drop-down arrow, in (RTL) FF OS. 

I don't now if the issue from FF OS and this one from Win7 have the same root. Please let me know if another bug should be filled. 
Thank you!
Flags: needinfo?(jfkthame)
(Assignee)

Comment 20

3 years ago
It's possible the FFOS issue will have been fixed by this patch, but I'm not entirely sure. It would be best to test a current trunk build on a device to verify whether it is fixed.
Flags: needinfo?(jfkthame)

Comment 21

2 years ago
Unfortunately, the drop-down arrow is still misaligned in FF OS 2.0 (build: 20150716000204)
What should be do next? 
Thanks!
(Assignee)

Comment 22

2 years ago
(In reply to ValentinaP from comment #21)
> Unfortunately, the drop-down arrow is still misaligned in FF OS 2.0 (build:
> 20150716000204)
> What should be do next? 

I doubt FF OS 2.0 builds are using gecko trunk; I think you'll need to test a build with current gecko from mozilla-central to see if the fix here helps.

Comment 23

2 years ago
We tested on FF OS 2.5 (build: eng.cltbld.20150213.031717, the last build available on mozilla-central), and there is no arrow for the drop-down....so I suppose the fix erased the drop-down arrow?
I checked in Marketplace-stage and in AMO-dev.
Please see the screenshot: http://screencast.com/t/5LHVgfcdpQEc
(Assignee)

Comment 24

2 years ago
That doesn't sound like the desired behavior. It could be either a Gecko or Gaia bug; further investigation needed. Please file a new bug.

Comment 25

2 years ago
(In reply to Jonathan Kew (:jfkthame) from comment #24)
> That doesn't sound like the desired behavior. It could be either a Gecko or
> Gaia bug; further investigation needed. Please file a new bug.

Thanks for the answer.
QA Whiteboard: [good first verify]

Comment 26

2 years ago
I have reproduced the bug with Nightly of 41.0a1 (2015-06-16) on my Windows 7, 64 Bit!

The bug's fix is verified now on Latest Nightly 43.0a1!

Build ID 20150816091433
User Agent Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

[testday-20150821]
Successfully reproduce this bug on Nightly 41.0a1 (2015-06-16) (Build ID: 20150616030201) with the instruction from comment 0 on Linux x64

This Bug is now verified as fixed on Latest Developer Edition 42.0a2 (2015-09-05) (Build ID: 20150905004017) and
Latest Beta 41.0b7 (Build ID: 20150903133607)

Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

As it is also verified on Windows (Comment 26), Marking it as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [good first verify][bugday-20150902]
status-firefox41: fixed → verified
status-firefox42: fixed → verified
You need to log in before you can comment on or make changes to this bug.