Mozilla calls "save as" dialog when I click on asp

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: light, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7) Gecko/20011221
BuildID:    20011221

hi, 

I tried to call an asp page named "call.asp" and when there is no page such
named,  the "save as..." page has been opened. I tried several times and it
gives the same response..


Reproducible: Didn't try
Steps to Reproduce:
1.find a link to asp page that does not exist
2.click on link
3.you will see it.
wfm with win2k build 20011229..

Tested on "http://www.mversen.de/test.html"

Have you tried it locally or on a server ?

Comment 2

17 years ago
Reporter, have you tried with other browsers ? What is the mime type of the
standard 404 page, what server are you running, etc. ?
Please mention an URL where anyone can test and see the problem.
(Reporter)

Comment 3

17 years ago
I saw this on internet not locally. I tried the same page with internet explorer. it gave 404 not 
found error. I did not try with opera. My server is NT. Which page I see this error was in a password 
protected site in HP. After your questions, I try to find the page but I could not. I will try give 
answer if I could find the page. 
If you find the page, can you attach a screenshot of that "Save dialog" ?
I think the problem is a wrong mime-type of the 404 error page.
IE use content sniffing and displays a page with a wrong mime-type.

Comment 5

17 years ago
->File Handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: doronr → sairuh

Comment 6

17 years ago
Reporter: Where you able to find the .asp page that produced the save as dialog?
marking worksforme (because it does for everyone I can find, myself included). 
adnan_uludag, please reopen if you can point us to a url that has this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.