Status

()

Firefox
Screen Sharing Whitelist
P5
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: michael.gorham, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
>> Vendor name
CraniumCafe.com

>> Point of contact
Michael Gorham

>> Site URLs
https://*.craniumcafe.com

>> Does the application provide users with notice and control?
https://www.craniumcafe.com/privacy-policy/

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes

Comment 1

3 years ago
the privacy statement and how info is used is not aligned with our policies - basically capturing all private info and sharing at will.  will respond more later.
Priority: -- → P5
(Reporter)

Comment 2

3 years ago
agreed ... that was a pretty boiler plate privacy statement we used.  we're very eager to get our domain whitelisted.  would it help to base our privacy statement off of Mozilla's example?  E.g., https://www.mozilla.org/en-US/privacy/
Sorry for the delay.  If you can update your policy to align with Mozilla's privacy statement (as you mention in your last comment) and include screensharing in your new privacy policy -- explicitly stating that you will not record or share the user's data with anyone other than the user intends, that would be sufficient.  Thanks.
Flags: needinfo?(michael.gorham)
(Reporter)

Comment 4

2 years ago
(In reply to Maire Reavy [:mreavy] (Plz ni?:mreavy) from comment #3)
> Sorry for the delay.  If you can update your policy to align with Mozilla's
> privacy statement (as you mention in your last comment) and include
> screensharing in your new privacy policy -- explicitly stating that you will
> not record or share the user's data with anyone other than the user intends,
> that would be sufficient.  Thanks.


Privacy Policy updated ...
https://www.craniumcafe.com/privacy-policy/

Specifically ...
"When using the SERVICE to communicate with College Counselors, Faculty or Staff via an online meeting, the SERVICE includes an option to record the meeting, including webcam audio and video and any shared screens.  These recordings are used for auditing, training and quality assurance purposes and are never shared with anyone other than the parties that attend the meeting.  All parties attending a meeting must agree in order to release recordings as viewable by any other party."

Also to note, we explicitly state before joining a Cranium Cafe webRTC meeting, that the meeting audio, video and screen share can be recorded.
Flags: needinfo?(michael.gorham)

Comment 5

a year ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.