Closed Bug 1175323 Opened 5 years ago Closed 5 years ago

Bump stdc++-compat minimum supported libstdc++ version

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox41 fixed)

RESOLVED FIXED
mozilla41
Tracking Status
firefox41 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file, 1 obsolete file)

The stdc++compat check in config/config.mk rejects symbols with versions GLIBCXX_3.4.9 and bigger, which correspond to being compatible with libstdc++ 4.1.1.

BUT:
- Firefox system requirements have been saying the minimum supported libstdc++ is 4.3 for a while (at least 4.0: https://www.mozilla.org/en-US/firefox/4.0/system-requirements/ )
- The oldest distros we support with our binaries are, afaik, RHEL/Centos 6.0 and SLES 11sp1. The former comes with libstdc++ 4.4. The latter with libstdc++ 4.3.

So it would seem we can safely bump to actually requiring libstdc++ 4.3.
Attached patch Patch (obsolete) — Splinter Review
Attachment #8623339 - Flags: review?(nfroyd)
Assignee: nobody → mh+mozilla
Attached patch PatchSplinter Review
Err, with the right update for the check.
Attachment #8623339 - Attachment is obsolete: true
Attachment #8623339 - Flags: review?(nfroyd)
Attachment #8623344 - Flags: review?(nfroyd)
Attachment #8623344 - Flags: review?(nfroyd) → review+
https://hg.mozilla.org/mozilla-central/rev/2677f3e14506
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.