Tracking protection list needs to be stored per session

RESOLVED DUPLICATE of bug 1145503

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1145503
3 years ago
2 years ago

People

(Reporter: bgrins, Unassigned)

Tracking

40 Branch
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxprivacy])

(Reporter)

Description

3 years ago
We can't leak which sites a user has chosen to allow tracking elements on.  This is especially a concern when entry to the 'allowed sites' list was added via Private Browsing mode.

This also implies, I think, that we have different stores for private browsing whitelisted sites and normal whitelisted sites.  The private browsing sites would definitely be transient and end after a session.  The normal browsing sites could potentially persist across sessions, although that would require different UX messaging in the control center (i.e. 'Enable protection for this site' vs 'Enable protection for this session').
Flags: firefox-backlog?

Updated

3 years ago
Flags: firefox-backlog? → firefox-backlog+

Updated

3 years ago
Rank: 3
Javaun said that Francois was looking into this so there may be an existing bug filed.
Flags: needinfo?(francois)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(francois)
Resolution: --- → DUPLICATE
Duplicate of bug: 1145503

Updated

3 years ago
Priority: P1 → --

Updated

3 years ago
Rank: 3
You need to log in before you can comment on or make changes to this bug.