./build/mozconfig.common.override not included by all B2G mozconfigs

RESOLVED DUPLICATE of bug 1156619

Status

RESOLVED DUPLICATE of bug 1156619
3 years ago
3 years ago

People

(Reporter: njn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
./build/mozconfig.common.override is supposed to be included by all mozconfigs. But it's not getting included in some try builds. From bug 1173076 comment 3:

> That try build claims to have used gonk-misc
> 3477513bcd385571aa01c0d074849e35bd5e2376's default-gecko-config, so this file:
> https://github.com/mozilla-b2g/gonk-misc/blob/3477513bcd385571aa01c0d074849e35bd5e2376/default-gecko-config
> 
> The first thing that does is include b2g/config/mozconfigs/common, which
> includes build/mozconfig.common, which includes build/mozconfig.automation
> and that's all.
> 
> Unlike all other mozconfigs, it doesn't have
> . "$topsrcdir/build/mozconfig.common.override" at the end.

I hit this when looking at a "B2G ICS Emulator debug" test job, but it may affect others as well.
(Reporter)

Comment 1

3 years ago
mwu, glandium thought you might know about this.
Flags: needinfo?(mwu)

Comment 2

3 years ago
Well, if you submit a PR to add the override to the end of gonk-misc/default-gecko-config, I'll take it.
Flags: needinfo?(mwu)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1156619
You need to log in before you can comment on or make changes to this bug.