[Contacts][ICE] When changing an ICE contact, I'm unable to select the person who already occupies that slot - I get a dialog saying "This contact is already an existing ICE contact"

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

STR:
 1. Open contacts app.
 2. Tap gear icon in upper-right.
 3. Tap "Set ICE Contacts"
 4. Enable ICE Contact 1, and underneath it, tap "Select a contact", and choose someone.
 5. Tap the same button underneath ICE contact 1 (which now shows a person's name).  Choose the same person again.

ACTUAL RESULTS:
An error message appears, saying:
  "This contact is already an existing ICE contact"
 
EXPECTED RESULTS:
Contact should just be accepted (into the same slot where they're already set).


Basically: if you start to change an ICE contact, and you end up deciding to stick with the same person, you *have* to hit "cancel". You can't simply choose that person from your contacts, because they're "already an existing ICE contact".  This is just silly.
Summary: [Contacts][ICE] When choosing a new ICE contact, I'm unable to pick the person who already occupies that slot → [Contacts][ICE] When changing an ICE contact, I'm unable to chooes the person who already occupies that slot - I get a dialog saying "This contact is already an existing ICE contact"
Summary: [Contacts][ICE] When changing an ICE contact, I'm unable to chooes the person who already occupies that slot - I get a dialog saying "This contact is already an existing ICE contact" → [Contacts][ICE] When changing an ICE contact, I'm unable to select the person who already occupies that slot - I get a dialog saying "This contact is already an existing ICE contact"
(I assume this dialog/restriction is *trying* to prevent me from choosing the same person as both ICE contact #1 and #2. That makes sense.  But, when I'm picking a person for ICE contact #1, Firefox OS should allow me to select the person who already holds that title, without there being any problem.)
QA wanted for a branch check.
Keywords: qawanted
This issue is reproducible on all branches that support ICE contact (Flame 3.0, 2.2, and 2.1).

Observed behavior: I have contact A, and I set A as my ICE contact. Now I want to change my ICE, but I pick A again. The app gives me an error "This contact is already an existing ICE contact", and I can only "OK" the dialog. After OK'ing the dialog, it doesn't change any outcome - I still have A as my ICE.

Device: Flame 3.0
BuildID: 20150617010205
Gaia: 6271f932e1e918a35ee89f54288bd13385143a71
Gecko: d7c148c84594
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame 2.2
BuildID: 20150617002504
Gaia: 3414b07dc489976bf510fd8042c0af3b1192c160
Gecko: a2db74491088
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150617001205
Gaia: f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gecko: 0ebea88c344d
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I'm tempted to close this bug as worksforme, since the current behaviour was the intented one.

The reasoning for displaying that message was to make sure that when you select a new ICE contact you choose a different one that is not already an ICE contact.

Johan, wdyt?
Flags: needinfo?(jlorenzo)
I agree, the behavior implemented is the intended one. However, it might be a good idea to let the user choose a contact set to the 1st ICE contact and automatically remove the contact from that 1st slot. It seems like a less punitive experience.

NI'ing UX to chime in.
Flags: needinfo?(jlorenzo) → needinfo?(hhsu)

Comment 6

3 years ago
I don't see this as a punitive experience to the user. The dialog is just a warning to the user that the selected contact already exists as an ICE contact. When user presses OK, the user is taken back to the contact picker page where user can still decide to select other contacts or press X to leave.
Flags: needinfo?(hhsu)
Okay, thanks for the feedback. Let's close this bug as WONTFIX, then.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.