OSX 10.6: "Minimize/Maximize/Close" buttons disappear after a video is viewed in full screen mode and you return to normal mode

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: baubau1907, Unassigned, NeedInfo)

Tracking

({in-triage})

38 Branch
in-triage
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8623504 [details]
print_screen.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Firefox 38.0.5 in Mac OS X has a bug, after a full screen mode.


Actual results:

After a video is viewed in full screen mode, the "Minimize/Maximize/Close" buttons are suddenly disappear. Requires restart Firefox for repair.


Expected results:

the "Minimize/Maximize/Close" should be always present.
Please see the print screen: I no longer have "Minimize/Maximize/Close" buttons.

Updated

3 years ago
Keywords: in-triage
Summary: "Minimize/Maximize/Close" buttons are suddenly disappear after a video is viewed in full screen mode. Requires restart Firefox for repair. In Mac OS x → OSX 10.6: "Minimize/Maximize/Close" buttons disappear after a video is viewed in full screen mode and you return to normal mode

Comment 1

3 years ago
Have you tried if you see this issue in a new profile, too? You can find details on how to create a new profile (without changing anything in your regular profile!) at https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles .

Have you tried if you see this issue in Firefox's safe mode, too? You can restart Firefox into safe mode by using the 'Restart Firefox with add-ons disabled' entry in the 'Help' menu. This will also disable graphics hardware acceleration and some JS engine optimizations, not just extensions and plugins. See https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode .
Flags: needinfo?(baubau1907)

Comment 2

3 years ago
The problem remains in a new profile. The problem remains in safe mode. The problem remains in Firefox 39.

A similar problem can be seen when not using a video but just when using the "Enter Full Screen" menu item's keyboard shortcut. With a browser window open, press Command-Control-F to enter full screen mode, wait until the menu bar hides and the title bar and address bar slide up off the top of the screen, then press Command-Control-F again, and the close, minimize and zoom buttons are gone.

It's not necessary to restart Firefox to fix the problem; it suffices to close the window and open a new one.

Comment 3

3 years ago
I also have this issue after viewing a full screen video on youtube. I have to close (command+q) and restart Firefox to get the buttons back.

Comment 4

3 years ago
Firefox 40.0 seems to have fixed it. Tried a fullscreen video on youtube plus an html5 video on my website. :D

Comment 5

3 years ago
baubau1907, Thank you for taking time to report this.
Are you still able to reproduce this in the latest version ?

Comment 6

2 years ago
Closing this as works for me. It is not reproducible in the latest version. 
Please feel free to reopen the bug if the issue reproduces in the current versions. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.