item list text doesn't use all space because of previous aligned image

RESOLVED DUPLICATE of bug 143162

Status

()

Core
Layout: Floats
--
trivial
RESOLVED DUPLICATE of bug 143162
16 years ago
14 years ago

People

(Reporter: Grzegorz Adam Hankiewicz, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Say you have an image tag aligned to the right, and next an unordered list with
lot's of <li> tags and plain text. If the first item starts _after_ the image
height ends, the text flow will be rendered correctly. Otherwise, if the first
list item starts before the image height ends, all the following text (including
following <li> tags) won't fill the whole width of the page.

To see this go to the above URL, search for the text "(CEST)" without quotes and
the next image shows the problem. You may have to play with the browsers window
width to see how the <li> text is rendered differently.
(Reporter)

Comment 1

16 years ago
Created attachment 63133 [details]
Screen capture of browser showing the bug
(Reporter)

Comment 2

16 years ago
Created attachment 63134 [details]
Same page with smaller window width makes the bug vanish
(Reporter)

Comment 3

16 years ago
Created attachment 63136 [details]
HTML source of the testcase used to show the bug

Please play with your browser's window width to see how the text of the <li>
elements change depending on wheter the first item is rendered after the first
image or not.
Grzegorz, what build are you using?
(Reporter)

Comment 5

16 years ago
O, sorry about that, I didn't see any place in the forms to put that
information. According to the about: page...

Mozilla 0.9.7
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/2001122108

Comment 6

16 years ago
Confirming in the Jan 03rd build (2002-01-03-08) build under Mac OS X.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Target Milestone: --- → Future
(Reporter)

Comment 7

15 years ago
Build 2002020415 shows this bug too.
Keywords: testcase
See also bug 136792 for similar behavior.
*** Bug 136792 has been marked as a duplicate of this bug. ***
This is caused by the -moz-float-edge setting we have on <li>.  Instead of
flowing around floats, <li>s just resize to avoid them.  Dupping to bug that
covers that.

*** This bug has been marked as a duplicate of 143162 ***

*** This bug has been marked as a duplicate of 143162 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Layout → Layout: Floats
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.