Img with 2x srcset specified has weird spacing when inside float

RESOLVED DUPLICATE of bug 1149357

Status

()

RESOLVED DUPLICATE of bug 1149357
3 years ago
2 months ago

People

(Reporter: menkra, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36

Steps to reproduce:

Originally asked here: https://stackoverflow.com/questions/30873562/firefox-img-with-2x-srcset-specified-has-weird-spacing-when-inside-float

TL;DR: On a "retina" screen, when an img with 2x srcset is inside a floated div that has unspecified width, the space allotted to the floated div equals the native resolution of the 2x image, instead of the "computed" width.

Recreated here: http://codepen.io/mendel/pen/dozedg/


Actual results:

200px width allotted to the div.left 


Expected results:

100px width should be allotted to the div.left

Comment 1

3 years ago
This is a good testcase, I'm guessing it belongs in layout.
Component: Untriaged → Layout: View Rendering
Thank you for the bug report and testcase!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149357
(Assignee)

Updated

2 months ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.