Closed Bug 1175590 Opened 5 years ago Closed 1 year ago

Intermittent webgl-capturestream-test.html?preserve | image comparison (==), max difference: 255, number of differing pixels: 65536

Categories

(Core :: WebRTC: Audio/Video, defect, P4)

x86
Windows XP
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox41 --- affected

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: intermittent-failure)

Test is blank, reference is a green square.

08:08:04 INFO - REFTEST TEST-START | file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
08:08:04 INFO - RESTORE PREFERENCE pref(webgl.force-enabled,false)
08:08:04 INFO - SET PREFERENCE pref(webgl.force-enabled,true)
08:08:04 INFO - SET PREFERENCE pref(canvas.capturestream.enabled,true)
08:08:04 INFO - REFTEST TEST-LOAD | file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve | 4486 / 12529 (35%)
08:08:04 INFO - RESTORE PREFERENCE pref(canvas.capturestream.enabled,false)
08:08:04 INFO - RESTORE PREFERENCE pref(webgl.force-enabled,false)
08:08:04 INFO - SET PREFERENCE pref(webgl.force-enabled,true)
08:08:04 INFO - SET PREFERENCE pref(canvas.capturestream.enabled,true)
08:08:04 INFO - REFTEST TEST-LOAD | file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/wrapper.html?green.png | 4486 / 12529 (35%)
08:08:04 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve | image comparison (==), max difference: 255, number of differing pixels: 65536
08:08:04 INFO - REFTEST IMAGE 1 (TEST): 
08:08:04 INFO - REFTEST IMAGE 2 (REFERENCE): 
08:08:04 INFO - REFTEST INFO | Saved log: START file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
08:08:04 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
08:08:04 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 0 rects
08:08:04 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
08:08:04 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
08:08:04 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 8 8 264 264
08:08:04 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
08:08:04 INFO - REFTEST INFO | Saved log: DoDrawWindow 8,8,256,256
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_SPELL_CHECKS
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: Completed
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
08:08:04 INFO - REFTEST INFO | Saved log: RecordResult fired
08:08:04 INFO - REFTEST INFO | Saved log: START file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/wrapper.html?green.png
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
08:08:04 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
08:08:04 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
08:08:04 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
08:08:04 INFO - REFTEST INFO | Saved log: RecordResult fired
08:08:04 INFO - REFTEST INFO | Loading a blank page
08:08:04 INFO - REFTEST TEST-END | file:///C:/slave/test/build/tests/reftest/tests/dom/canvas/test/reftest/webgl-capturestream-test.html?preserve
Flags: needinfo?(pehrsons)
This only happens on WinXP pgo builds it seems. I'll note it was much more common on Win7 and Win8 and thus got disabled there. See bug 1174056.
Flags: needinfo?(pehrsons)
See Also: → 1174056
Component: Audio/Video → WebRTC: Audio/Video
Andreas - how is this related to bug 1207546?
Rank: 35
Flags: needinfo?(pehrsons)
Priority: -- → P3
They saw failures of the same reftest in bug 1207546 so I was thinking a timing issue could have been triggered. Turned out to be because the media element was paused due to muting, or something like that. So, not related after all.

I think there's some sort of gfx/timing issue behind this on Windows, and IIRC, B2G.
Flags: needinfo?(pehrsons)
See Also: 1207546
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.