64Bit: Impossible to make Mail/News default application for "send from WIN Explorer", "Send document (as PDF)" ...

RESOLVED DUPLICATE of bug 393302

Status

--
minor
RESOLVED DUPLICATE of bug 393302
4 years ago
3 years ago

People

(Reporter: RainerBielefeldNG, Unassigned)

Tracking

({64bit})

x86_64
Windows 7
64bit

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Steps how to reproduce with DE SeaMonkey 2.35(a)  (Windows NT 6.1; Win64; x64; rv:38.0 nightly by Adrian Kalla)  Gecko/20100101 Build 20150615204754 (Classic Theme) on German WIN7 64bit:

1. Uninstall Seamonkey 2.33.1
2. Install above mentioned Version in c:\Program Files\
3. If necessary: Menu 'Edit  → Prferences → Mail & Newgroups → Make
   SM Default application for Mail, News, Feeds'
   (I had to do that for Mail, News)
4. Try to send an ODF (OpenOffice) document as PDF via e-mail
   expected: SM opens, Mail Composer opens new mail with PDF attachment
   actual: Nothing happens for running Seamonkey, MS Browser
           will open if SM did not already run

Additional information:
a) This as an inofficial build, so currently low priority
b) Default installation folder for this version was "c:\Program Files\"
   instead of "c:\Program Files (x86)\", I can't tell whether that
   is related (I am used to see  ...(x86)". 
   One attempt to intall in ...(x86) failed, I had to stop that after
   20 minutes.
c) In step 4 Win will ask for Administrator permissions, so it seems
   that something happens as expected, and the 2 buttons in
   SM dialog ([Mail], [News] will be greyed out later, and become active
   after I will have made TB default Mail app for testing.
   But SM 35 will not become default Mail application, although some SM
   I don't know how to find what SM) is
   listed in WIN Standard Programs Dialog as default application for
   Mail.
(Reporter)

Comment 1

4 years ago
d) uninstall 2.35 and installation of EN-US SeaMonkey 2.33.1 (German Language 
   pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit
   heals the problem, that version becomes default mail application as expected.
e) I am not sure, but I think I also observed that problem with an other 2.35 
   64 Bit build
f) I will try a 2.35 32 bit build later.
(Reporter)

Comment 2

4 years ago
g) Works fine with 32Bit DE SeaMonkey 2.35(a) (Windows NT 6.1; WOW64; rv:38.0 
   nightly by Adrian Kalla) Gecko/20100101 Build 20150615204754 (Classic Theme) 
   on German WIN7 64bit
g1) So probably 64Bit build problem?
g2) Or related to location of installation "c:\Program Files\" instead of 
    "C:\Program Files (x86)\"?

@Adrian: What do you think?
Summary: Impossible to make Mail/News default application for mailto:, send from WIN Explorer, ... → 64Bit: Impossible to make Mail/News default application for mailto:, send from WIN Explorer, ...
(In reply to Rainer Bielefeld from comment #2)
> g) Works fine with 32Bit DE SeaMonkey 2.35(a) (Windows NT 6.1; WOW64;
> rv:38.0 
>    nightly by Adrian Kalla) Gecko/20100101 Build 20150615204754 (Classic
> Theme) 
>    on German WIN7 64bit
> g1) So probably 64Bit build problem?
> g2) Or related to location of installation "c:\Program Files\" instead of 
>     "C:\Program Files (x86)\"?
> 
> @Adrian: What do you think?

It's definitely not g2). With a 64 bit Windows, "C:\Program Files (x86)" is reserved for 32 bit applications and "C:\Program Files" for 64 bit applications.
Because of that, SeaMonkey 64 bit installation into "C:\Program Files" is absolutely correct.

So at the end, it'll be g1). It would be interesting to know, if this also affects Thunderbird and/or (somehow) Firefox.
(Reporter)

Comment 4

4 years ago
(In reply to Adrian Kalla [:adriank] from comment #3)
> So at the end, it'll be g1). It would be interesting to know, if this also
> affects Thunderbird and/or (somehow) Firefox.

I will check that during weekend.
(Reporter)

Comment 5

4 years ago
I tried "Thunderbird 41.0a1 (2015-06-19)"
h) TB 64 Bit shows more or less the same problems.
h1) Mailto links will use TB correctly
h2) Send to email recipient from WIN Files Explorer: will crash Thunderbird
h3) Send Document as PDF from AOO

I will have to check "Mailto" for seamonkey again.
Component: OS Integration → Backend
Product: SeaMonkey → MailNews Core
Summary: 64Bit: Impossible to make Mail/News default application for mailto:, send from WIN Explorer, ... → 64Bit: Impossible to make Mail/News default application for "send from WIN Explorer", "Send document (as PDF)" ...
Version: SeaMonkey 2.35 Branch → 41
(Reporter)

Comment 6

4 years ago
i) Mailto: works fine, SeaMonkey 2.35(γ)  (Windows NT 6.1; Win64; x64; rv:38.0 
   nightly by Adrian Kalla)  Gecko/20100101 Build 20150615204754 becomes standard
   email application for mailto: links as expected.
(Reporter)

Updated

4 years ago
Keywords: 64bit
(Reporter)

Comment 7

4 years ago
At least "Impossible to make Mail/News default application for "send from WIN Explorer"," isa DUP of "Bug 393302 - Can't "send-to" (MAPI) using Seamonkey and Thunderbird X86_64"
See Also: → bug 393302

Updated

4 years ago
Blocks: 471090
isn't this a duplicate of bug 393302?
(Reporter)

Comment 9

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #8)
My suspect, too. But not yet tested all aspects.

I found a possibly related Linux SeaMonkey "Bug 1226839 - Impossible to make Mail/News default application (for "send from WIN Explorer", "Send document (as PDF)", "mailto:")", some aspects are similar, some are completely different.
See Also: → bug 1226839
(Reporter)

Comment 10

3 years ago
DUP for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 393302
Duplicate of bug: 393302
You need to log in before you can comment on or make changes to this bug.