Autophone - webappstartup fails to detect measurements

RESOLVED FIXED in Firefox 41

Status

()

Firefox for Android
Testing
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bc, Assigned: esawin)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 41
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed, fennec41+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Beginning with https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=ba34e5e4111a&filter-searchStr=autophone&exclusion_profile=false webappstartup fails to report measurements.

Looks like bug 1171013. esawin: Can we back this out? It is causing me pain.
(Reporter)

Comment 1

3 years ago
disabled on everything except try for now.
Eugen, can you get this back to green?
Component: General → Testing
Flags: needinfo?(esawin)
(Reporter)

Comment 3

3 years ago
I did a series of try builds starting before the patch in bug 1171013

See https://treeherder.mozilla.org/#/jobs?repo=try&exclusion_profile=false&filter-searchStr=android&author=bclary@mozilla.com&startdate=2015-06-17&enddate=2015-06-18

The issue really became apparent with the third patch.
https://bug1171013.bugzilla.mozilla.org/attachment.cgi?id=8621564

The nexus 7 is showing partial failures with the run 1 of 8 with the second patch but it is a notoriously flaky device anyway.
(Assignee)

Comment 4

3 years ago
The issue is that WebappManager expects the DOMApplicationRegistry to be ready on autoInstall, which is triggered when we try to re-install a webapp from the same location.

I have a patch ready soon, looks good so far: https://treeherder.mozilla.org/#/jobs?repo=try&revision=54f40b1f8e5f&exclusion_profile=false
Flags: needinfo?(esawin)
(Assignee)

Updated

3 years ago
Assignee: nobody → esawin
tracking-fennec: ? → 41+
(Assignee)

Comment 5

3 years ago
Created attachment 8624350 [details] [diff] [review]
0001-Bug-1175605-Do-not-access-DOMApplicationRegistry-pro.patch

With bug 1171013 we've introduced lazy-loading of Webapps.jsm, so we cannot depend on DOMApplicationRegistry being ready on startup.

This patch ensures that we don't try to auto-update webapps before the registry is loaded and ready.

The change in browser.js is just a precaution, as currently it is safe to call receiveMessage on a non-fully initialized registry.
Attachment #8624350 - Flags: review?(myk)
Comment on attachment 8624350 [details] [diff] [review]
0001-Bug-1175605-Do-not-access-DOMApplicationRegistry-pro.patch

Review of attachment 8624350 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, and it should work correctly, as the lone caller of WebappManager.autoInstall doesn't depend on the timing of the _autoUpdate call.
Attachment #8624350 - Flags: review?(myk) → review+
(Reporter)

Comment 9

3 years ago
That won't actually run the autophone tests. We don't kick off autophone for -u all since most people don't care about autophone until they need to and autophone would suffer a DOS. I'll submit them autophone-webapp for you.
https://hg.mozilla.org/mozilla-central/rev/3c6b38653a58
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Assignee)

Comment 12

3 years ago
(In reply to Bob Clary [:bc:] from comment #10)
> Note you have to show hidden jobs to see autophone:
> 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=fee8497a9d9c&filter-
> searchStr=autophone&exclusion_profile=false

Thanks, I assume the 4.3 one is the Nexus 7? I've submitted the autophone results in comment 4.
(Reporter)

Comment 13

3 years ago
(In reply to Eugen Sawin [:esawin] from comment #12)

> Thanks, I assume the 4.3 one is the Nexus 7?

Yep. Not sure what is up with that. It was intermittent in the try runs I did last night. We'll see what it does going forward.
You need to log in before you can comment on or make changes to this bug.