Closed Bug 1175615 Opened 7 years ago Closed 6 years ago

ctrl+k changed and inconsistent behavior

Categories

(Firefox :: Keyboard Navigation, defect)

38 Branch
All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1176929

People

(Reporter: jnicol, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150603135958

Steps to reproduce:

upgraded to FF 38


Actual results:

ctrl+k should move the cursor to the search bar. Under normal conditions, it does. Here is the inconsistent behavior:

If your cursor is in the search bar (ctrl+f) with text highlighted, ctrl+k clears the selection. If nothing is selected, it does nothing.

If your cursor is in the address bar (ctrl+l) with text highlighted, ctrl+k clears the selection. If nothing is selected, it does nothing.


Expected results:

ctrl+k should move the cursor to the search bar in all situations.
Component: Untriaged → Keyboard Navigation
Note that ctrl+j (consistently) does what ctrl+k used to do. It's still an inconvenient change.
Likely duplicate of Bug 1176929?
Flags: needinfo?(jnicol)
(In reply to John Drinkwater (:beta) from comment #2)
> Likely duplicate of Bug 1176929?

That's a newer bug, but yes, same issue.
Flags: needinfo?(jnicol)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
OS: Unspecified → Linux
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1176929
You need to log in before you can comment on or make changes to this bug.