Several image-asset (PNG) 404s in the "Report this..." popup on the Demos page

RESOLVED WORKSFORME

Status

developer.mozilla.org
General
--
minor
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: stephend, Assigned: Florian Moussous, Mentored)

Tracking

({in-triage})

Details

(Whiteboard: [specification][type:bug])

Attachments

(1 attachment)

What did you do?
================
1. Load https://developer.mozilla.org/en-US/demos/
2. Open the Web Console, and select "Network"
3. Click on a demo
4. Click on any of the "Report..." links to the bottom right of the demo

What happened?
==============
See 3 404s:

https://developer.cdn.mozilla.net/media/css/images/ui-icons_ef8c08_256x240.png
https://developer.cdn.mozilla.net/media/css/images/ui-icons_222222_256x240.png
https://developer.cdn.mozilla.net/media/css/images/ui-bg_diagonals-thick_20_666666_40x40.png

What should have happened?
==========================
Images should have loaded and displayed

Is there anything else we should know?
======================================
Mentor: shobson
Severity: normal → minor
Keywords: in-triage
This is happening because we manually focus on the first hidden avatar after the user clicks the "show all" button.  I think we'll be able to prevent this issue by checking for 'ENTER' key specifically.
(Assignee)

Comment 3

3 years ago
There is actually at least one more 404:
https://developer.cdn.mozilla.net/static/css/images/ui-bg_glass_100_f6f6f6_1x400.png

May I work on this bug?
Assignee: nobody → florian.moussous
Sure Florian, I've assigned it to you, go ahead.
(Assignee)

Comment 5

3 years ago
Actually I can't reproduce the bug anymore... I had the 404s 2 days ago, but not anymore.
Is it just me?
(In reply to Florian Moussous from comment #5)
> Actually I can't reproduce the bug anymore... I had the 404s 2 days ago, but
> not anymore.
> Is it just me?

Was this fixed with bug 1197444 and/or one of its related bugs/dependencies?
(Assignee)

Comment 7

3 years ago
(In reply to Stephen Donner [:stephend] - please :need-info? me! from comment #6)

> Was this fixed with bug 1197444 and/or one of its related bugs/dependencies?

Maybe but I don't see how?
But I think it may be due to the switch to django-pipeline (see bug 1139490)?
The commit is big, I haven't read it all...
It's possible bug 1197444 inadvertently fixed this. I can't reproduce now, so I'm marking as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.