test_ftu_skip_tour.py: "Timeout Exception:Cell data was not connected by FTU app"

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
Test is failing after restarting the FTU and attempting to access the Enable Data Checkbox. Data becomes enabled before phone times out and fails.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/847/

Repro Steps:
1) Update phone to 20150617010205
2) In FTU, navigate past language menu
3) Enable Data

Actual:
Test enables data, then phone times out

Expected: 
Test enables data then proceeds through remainder of FTU


Traceback (most recent call last):
File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/ftu/test_ftu_skip_tour.py", line 54, in test_ftu_skip_tour
message='Cell data was not connected by FTU app')
File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1122, in wait_for_condition
Wait(self.marionette, timeout).until(method, message=message)
File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.1 seconds with message: Cell data was not connected by FTU app

Environmental Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	17 Jun 2015 08:45:16
Device firmware (incremental) 	eng.cltbld.20150617.044504
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	e472d8d7
Device uptime 	0 days 0 hours 2 minutes 14 seconds
Gaia date 	16 Jun 2015 20:43:35
Gaia revision 	6271f932e1e9
Gecko build 	20150617010205
Gecko revision 	d7c148c84594
Gecko version 	41.0a1


Reproducible manually: NO

Repro frequency: 5/5


** Test has been disabled for some time due to bug 1134257, changes may have interfered as it failed on a line that was modified.
When I do this manually, toggling the "Enable Data" checkbox in the FTU app doesn't connect the device to cell data, so this looks like a real product bug to me, which apparently regressed recently.
It seems to work with:
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk-eng/2015/06/2015-06-16-01-02-05/
Build ID               20150616010205
Gaia Revision          62ba52866f4e5ca9120dad5bfe62fc5df981dc39
Gaia Date              2015-06-15 19:09:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ce863f9d8864

And it fails with:
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk-eng/2015/06/2015-06-16-16-02-06/
Build ID               20150616160206
Gaia Revision          9d42e94446f2dc01b519172b6d75d81d4d435bdc
Gaia Date              2015-06-16 16:16:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/27caa5299f9f
Keywords: regression
Oliver, can you confirm this? That the "Enable Data" checkbox in the FTU app has stopped working with the regression range in comment 2?
Flags: needinfo?(onelson)
Created attachment 8624711 [details] [review]
Make this test expected  = fail for now

I'll make this test expected = fail for now.
(Reporter)

Comment 5

3 years ago
Confirming with comment 1, this does reproduce manually, contrary to original logging.
Filed product bug 1176251 to confirm this behavior.
Will confirm regression range of comment 3 shortly.
Flags: needinfo?(onelson)
(Reporter)

Updated

3 years ago
See Also: → bug 1176251
This will be fixed by bug 1175861, so as soon as that lands, I'll remove the expected = fail entry.
Depends on: 1175861
Oh, *doh*, I didn't merge the original pull request yet, because the tree was closed. I just won't bother doing that then, since bug 1175861 since to be on the verge of being fixed.
Should be fixed now by bug 1175861.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.