On first start, clicking on Bookmarks in menu bar causes unexpected quit

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: dennis, Assigned: bugs)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.7+)
Gecko/20011228
BuildID:    2001122809

On my iMac (slot loading 400 MHz) I've just started using Mac OS X 10.1.2.  I
started Mozilla from an icon in the folder window toolbar.  The Mozilla start
page comes up as default start page.  Everything looks normal including Sidebar
with the latest news loaded.  When I click on Bookmarks choice in Apple Menu bar
or when I click and hold then choose any entry Mozilla quits with the OS X
message ...Unexpectedly Quit...

Reproducible: Always
Steps to Reproduce:
1. Boot Mac
2. Start Mozilla
3. Click on Bookmarks

Actual Results:  Mozilla quit, Mac OS X dispayed a message saying the
application had unexpectedly quit and other applications were not affected.

Expected Results:  Should have accessed bookmark list or gone to selected URL.

Comment 1

17 years ago
Works for me using that build (20011228-09) on MacOS X 10.1.1.

Is your bookmark file valid? Try moving the bookmark file to a different name
and restarting Moz - it should create a new empty bookmark file. If the bug goes
away then it looks like a corrupt bookmark file.

Can you access the bookmarks via the personal toolbar?
Summary: On first start, clicking on Bookmarks in menu bar causes unexpected quit → On first start, clicking on Bookmarks in menu bar causes unexpected quit

Comment 2

17 years ago
Works for me with this build and communication with the reporter reveals that it
works with a fresh bookmarks file. What caused the bookmark file to become
corrupt should be the subject of another bug if its Mozilla usage.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.