Make help an optional install

VERIFIED DUPLICATE of bug 89603

Status

SeaMonkey
Help Documentation
VERIFIED DUPLICATE of bug 89603
16 years ago
13 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Ian Oeschger (gone))

Tracking

1.0 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The help files that come with navigator should be deselectable in the custom
install. They are almost 300k compressed, and 830k uncompressed. This would save
download time (specially if you download a new build daily) and disk space for
advanced users who don't intend to use them.

Most other apps with a help system allow you to not install the content.

Similarly, if you only install Navigator and now Mailnews, You shouldn't get
help files for Mail and News subjects. Can 3rd party Mozilla apps install their
own help content? I suspect not as the index seems static. This is very flawed.

Comment 1

16 years ago
-->ian.
Assignee: rudman → oeschger
(Assignee)

Comment 2

16 years ago
Have to get rid of some of the dependencies described in 89603
Depends on: 89603
(Assignee)

Comment 3

16 years ago
Like to work on this with some of the installer folks. ACCEPTing and seeking help.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

16 years ago
nominating nsbeta1. talked with dveditz who made it sound doable. And good,
footprint-wise, product-wise.
Keywords: nsbeta1
(Reporter)

Comment 5

16 years ago
Since this is desirable to NSCP all of a sudden, I sincerly suggest you consider
bug 29838 (make composer app optional, leave editor core) as well. It's 4xp and
would help quite a bit with user's mental image of our bloat. Out of sight, out
of mind.
(Assignee)

Comment 6

16 years ago
Roger on the optionality, jmd. I would like to see this happen to a greater
degree in the product, but I am coming at this from the Help side of things (and
working at the limits of my xpinstall-and-packaging-ken as it is). Perhaps we
can look into this as I try and get things going with this separation of the
Help system.

1) in the (mozilla and ns)/xpinstall/packager/package* lists create a [mozhelp]
section and move the appropriate files out of the [browser] section. Or would
you leave the content (code) and pull out the localized resources that are
currently in the language packs? help.jar in browser is only 12K so that hardly
seems worth it.

If it's the localized help that you're moving maybe [helpenus] would be better.
You'll also have to edit the aappropriate jar.mn to create a helpenus.jar
instead of lumping it all in en-US.jar

2) create six mozhelp.jst (or helpenus.jst) files (three moz, three ns) in the
appropriate platform directories under xpinstall/packager. The name must match
the section name in the package files. These can be effectively the same, except
the Mac versions use "viewer" as the root directory and unix and win use "bin"
(to match the package lists from step 1)

If you're talking about the localized help use langenus.jst as your model.
Slightly more complex than you need, but correctly handles the possibility that
the installation directory in unwritable. In the "register chrome" section
remove everything except the one line that mentions help

3) add helpenus to makeall.pl in the win and linux directories (4 places). I
don't know where to put the mac version -- ask Samir

4) add helpenus sections following the langenus model in the 4 config.it files
for win and linux (where the makeall.pl were), and for the two mac versions down
in xpinstall/wizard/mac/macbuild/config.ini_tmpl

Since you want this to be an option don't use the INVISIBLE attribute that the
langenus component does,

5) coordinate with the Mozilla Localization Project and Netscape localization
teams. They'll have to change their build/translation procedures to match the
new location, and they'll have to figure out what to do when people go to
download a "language pack" -- does that include the help, or is that optional
there too? They may be using simple .xpi links, but it'll give users a better
experience if they can bundle the two packages into a single install:

  function installLangpack(lang, helpToo) {
     // lang is "enus" etc
     var packages = {lang+" language pack": urlbase+"lang"+lang+".xpi"};
     if (helpToo)
        packages[lang+" help"] = urlbase+"help"+lang+".xpi";
     InstallTrigger.install(packages);
   }
Keywords: nsbeta1
Keywords: nsbeta1

Comment 8

15 years ago
-> browser help
Component: User → Help
Product: Documentation → Browser
Version: unspecified → 1.0 Branch

Comment 9

15 years ago
this is a dupe

*** This bug has been marked as a duplicate of 89603 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 10

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.