Firefox addon element abnormally flashing using CSS animation on Mac

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
3 years ago
23 days ago

People

(Reporter: noitidart, Unassigned)

Tracking

39 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150611135623

Steps to reproduce:

The problem only happens on Mac:

This is written by user James_ from Stackoverflow: http://stackoverflow.com/questions/29972371/firefox-addon-element-abnormally-flashing-using-css-animation-on-mac 
 filed this because I have encountered the same behavior.

The 'Test Link' element flashes abnormally when used in a Firefox addon panel (sdk/panel) when compared to the [JSFiddle demo](https://jsfiddle.net/sozvga4g/1/) despite they share the same source code.

Firefox addon source code: https://drive.google.com/file/d/0BzHBWuszZv5_eWl1RTdIOW84NG8/view?usp=sharing

to run

download and unzip
```
$ cd CSSFlashing3; cfx run
```

Is there any workaround to the problem because who knows how long does it take for Mozilla to fix this?
(Reporter)

Comment 1

3 years ago
His test case runs in HTML, I have not encountered flashing there, however I have inserted some elements to to the australis main menu (tri-stipe menu) and it happens to me in the XUL.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
(Reporter)

Comment 2

3 years ago
Here is a screencast of my situation: https://www.youtube.com/watch?v=IEeGAjhhntw

We see a flash sometimes and sometimes that causes the mouseleave even to trigger, which causes my expanded menu to collapse. :(
Component: Untriaged → Extension Compatibility
Hi noitdart, 

Are you still encountering these issues on the newest version of Firefox (42)?
Flags: needinfo?(noitidart)
(Reporter)

Comment 4

2 years ago
(In reply to Grover Wimberly IV from comment #3)
> Hi noitdart, 
> 
> Are you still encountering these issues on the newest version of Firefox
> (42)?

I'll test it out and get back to you
(Reporter)

Comment 5

2 years ago
(In reply to Grover Wimberly IV from comment #3)
> Hi noitdart, 
> 
> Are you still encountering these issues on the newest version of Firefox
> (42)?

Just tested it, yes I am seeing the flashing :( And the flash causes the mouse off event to happen which closes the menu :(
Flags: needinfo?(noitidart)
(Reporter)

Comment 6

2 years ago
(In reply to Grover Wimberly IV from comment #3)
> Hi noitdart, 
> 
> Are you still encountering these issues on the newest version of Firefox
> (42)?

Here is a youtube screencast I recorded showing the animation flicker, and its side effect of triggering mouseleave event - https://www.youtube.com/watch?v=4WBWctui0fs

Comment 7

23 days ago
With WebExtensions being the only valid way of doing extensions in Firefox 57, I don't think this bug is still relevant.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 23 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.