Attributes created with setAttributeNode result in null when read with getAttribute

RESOLVED DUPLICATE of bug 1165851

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1165851
3 years ago
3 years ago

People

(Reporter: Volker Weiss, Unassigned)

Tracking

38 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8624235 [details]
setAttributeNodeTest.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

var elem = document.getElementById('test');
var attr = document.createAttribute('myAttrib');
attr.nodeValue = 'myValue';
elem.setAttributeNode(attr);
alert(elem.getAttribute('myAttrib'));


Actual results:

Returns null


Expected results:

Should resolve to "myValue". All other Browsers behave like this. FF did so until V36/37 (don't know exact point).

When Attribute is set via setAttribute('myAttrib', 'myValue') the result is as expected.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1165851
You need to log in before you can comment on or make changes to this bug.