Treeherder documentation should have a "retrieving data" section

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Details

Attachments

(1 attachment)

To correspond to our "submitting data" section in the treeherder docs (http://treeherder.readthedocs.org), we should also have a "retrieving data" section, which should cover both the REST API and the new python client API.
Duplicate of this bug: 1061235
Created attachment 8624273 [details] [review]
PR

This is just a stub to get started -- I plan on hacking a bunch to improve it (in particular, adding specific documentation for each method in treeherder-client), but let me know if you have any suggestions. :)
Attachment #8624273 - Flags: review?(mdoglio)
Attachment #8624273 - Flags: review?(mdoglio) → review+

Comment 3

4 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/1c129a5cc6b297e37315c5e9b8858ba532290c3c
Bug 1175935 - Add a section on "retrieving data" to docs

Currently documents the swagger interface to the REST API and the python
client API.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.