Dropdown list should scroll when dragging with mouse

RESOLVED DUPLICATE of bug 27315

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 27315
16 years ago
16 years ago

People

(Reporter: Ere Maijala (slow), Assigned: rods (gone))

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Should be able to scroll the combobox dropdown by dragging with mouse over the
top or bottom edge of the list. At least on Windows this is standard behavior.
One should be able to push the down arrow to show the list and keep the mouse
button down and scroll the list. Sometimes it will scroll one line up or down,
but usually it doesn't do anything. Scrolling speed should also depend on how
far from list area the cursor is.

Comment 1

16 years ago
I see this on OS X too, build 122106 (0.9.7 release).
are these dropdown lists in the browser UI or in web pages?

Comment 3

16 years ago
I wouldn't be surprised if this is a dup, but I can't find one right now.
(and I'm assuming that this is referring to menulists in the UI).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

16 years ago
Boris: The problem exists mostly in web pages. I'm using the Modern theme where
the lists usually have these arrows on top and bottom. They sort of do the
appropriate thing. Haven't tested Classic though. The problem DOES exist anyway
in the URL bar of the browser.

John: NO, I'm NOT talking about menus (if that is what you refer to with
"menulist"). I'm talking about what are commonly called comboboxes, these with
the down arrow to show a list of choices. As I'm not very well into XP toolkit
terminology, we might have a misunderstanding here.

Comment 5

16 years ago
Yeah, just a terminology thing; by 'menulist' I mean, as you say, "these 
with the down arrow to show a list of choices". [I don't mean 'menus' at all].

But, I confused by your comment to bz: "The problem exists mostly in web pages. 
I'm using the Modern theme where the lists usually have these arrows on top and 
bottom."

The two sentences are contradictory; you say you're talking about web pages, 
and then describe something that doesn't apply to web pages.
Ere, the thing is that web pages and the browser chrome use two completely 
different widgets.  The chrome ones are the ones used for font selection in the 
fonts panel.  Do those show this problem?  The url bar widget is yet a third 
widget in a world of its own and may need a bug separate from this one.

"menulist" is the chrome name for what one would call a <select size="1"> in 
HTML, so John is not confused.
(Reporter)

Comment 7

16 years ago
Guess I should have some coffee in the morning before writing anything :)

Anyway, what I meant to say was that the problem exists in web pages. It does
not exist at least so clearly in the chrome, because there are those arrows on
the top and bottom (at least with Modern theme). Of course the problem has a
much higher visibility on web pages also because in the UI there are not so many
of those long scrollable lists.
To HTML form controls.  ccing bryner, who's redoing the dropdown widget with 
xbl.....
Assignee: hyatt → rods
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: jrgm → madhur
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Summary: Dropdown list should scroll when dragging with mouse → [DUPDropdown list should scroll when dragging with mouse
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 27315 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: [DUPDropdown list should scroll when dragging with mouse → Dropdown list should scroll when dragging with mouse
You need to log in before you can comment on or make changes to this bug.