YouTube H264 videos not GPU decoded

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: davidkacerek, Unassigned)

Tracking

38 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150524020551

Steps to reproduce:

Start an YouTube video using h264 video format.


Actual results:

During playing the video, Firefox CPU usage went to 60%.


Expected results:

During playing the video, Firefox should use 10-20% of CPU.
(Reporter)

Comment 1

2 years ago
When playing an YouTube video in Chrome, it uses 10-20% of CPU so I guess it utilizes GPU decoding. When playing the same video in Firefox, CPU utilization goes up to 60% so I guess it uses software decoding. In both cases it's HTML5 video player (not Flash) with h264-encoded video.
(Reporter)

Comment 2

2 years ago
"media.windows-media-foundation.use-dxva" feature on the "about:config" page is set to its default "true" value.
Firefox is the latest stable one 38.0.6 (x64 build) installed on Win7SP1x64.
(Reporter)

Comment 3

2 years ago
Actually it's resolved itself, not sure what happened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Resolution: INVALID → WORKSFORME
Component: Untriaged → Video/Audio
Product: Firefox → Core
(Reporter)

Comment 4

2 years ago
The issue has returned, actually it never went away. It only worked correctly few times from reporting the bug. Don't know what caused it to work correctly. Tried to run Firefox in safe mode (with add-ons disabled) to no avail. 

Graphics section on the about:support page:
Graphics
Adapter Description	ATI Mobility Radeon HD 3650
Adapter Drivers	aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	256
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
Device ID	0x9591
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.17292)
Driver Date	11-16-2012
Driver Version	8.970.100.7000
GPU #2 Active	false
GPU Accelerated Windows	2/2 Direct3D 11 (OMTC)
Subsys ID	211717aa
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Mobility Radeon HD 3650 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

Could we re-open the bug?
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
Component: Audio/Video → Audio/Video: Playback
For now we can't support hardware decoding on many AMD GPUs. We're working with AMD engineers now and will hopefully find a GPU driver fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.