Status

()

defect
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: mt, Assigned: RyanVM)

Tracking

unspecified
mozilla41
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox38 unaffected, firefox39+ fixed, firefox38.0.5 unaffected, firefox40 fixed, firefox41 fixed, firefox-esr31 fixed, firefox-esr38 fixed, relnote-firefox 39+)

Details

(Reporter)

Description

4 years ago
NSS_3_19_2_RTM is ready.

NSS_3_19_2_WITH_CKBI_1_98_BRANCH  has been labelled for Firefox 31.

This isn't a critical update for us: NSS has no changes that we need.  However, it might be a good thing to do in case other applications depend on the version of NSS that we ship.

Ryan, Liz, if you feel like closing this WONTFIX, that's OK, otherwise, I'd recommend updating everywhere ahead of the next cycle.  This is a super-low risk change.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1176101
(Assignee)

Comment 2

4 years ago
I'm sorta-inclined to just take it a=NPOTB given that bug 1172128 doesn't affect Firefox at all.
Well, actually it kind of does since 3.19.1 affected whether some sites work with Firefox and there has been ongoing discussion about it. But yes let's get this into 39. It would be in the RC for Monday. 

Probably correct to also put it in ESR38. Sylvestre can you weigh in there?

Martin can you request uplift?
Flags: needinfo?(sledru)
Flags: needinfo?(ryanvm)
(Assignee)

Comment 4

4 years ago
My understanding is that the changes in 3.19.2 only affect other users of NSS, not Firefox. Taking this is more of a belts and suspenders thing more than anything else.
Flags: needinfo?(ryanvm) → needinfo?(lhenry)
In this case, not taking it for ESR then... Thanks for the information
Flags: needinfo?(sledru)
(Assignee)

Comment 6

4 years ago
Talked to Sylvestre about it on IRC and decided that this is probably OK to take as a ride-along but I'm not going to go out of my way to land it anywhere.
Flags: needinfo?(lhenry)
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/mozilla-central/rev/ae988833ad6b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla41

Updated

4 years ago
Duplicate of this bug: 1174102
(In reply to Sylvestre Ledru [:sylvestre] from comment #5)
> In this case, not taking it for ESR then... Thanks for the information

I'm glad you in fact landed on ESR.

I believe this NSS update was most important for ESR. As I said in 1174102 comment 5:

"Since Firefox 38.x might be used for SDK like scenarios, for example by people trying to use a xulrunner based on Firefox 38.x, I'd like to suggest that Firefox 38.x ESR gets udpated to pick up 3.19.2, too."

Updated

4 years ago
Blocks: 1172917
Duplicate of this bug: 1188607
You need to log in before you can comment on or make changes to this bug.