WebGL exiting fullscreen when not using esc key causing a residual image to stay around in Unity products

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
4 years ago
3 months ago

People

(Reporter: mbest, Unassigned)

Tracking

(Blocks 1 bug)

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games][gfx-noted], )

Attachments

(1 attachment)

I was scanning the Unity forums and came across this issue.  See URL for details.
Blocks: gecko-games
Whiteboard: [games]
Tried guessing a repro for this based on the comment "It happens when i use an exit fullscreen script/function linked to any other events or calls: mouse, game button, keys etc ....", and wrote the following two pages:

a. https://dl.dropboxusercontent.com/u/40949268/emcc/test_html5_fullscreen/test_html5_fullscreen.html
 1. Press any of the buttons to go to fullscreen.
 2. Press the 'E' button on the keyboard to programmatically go back.

b. https://dl.dropboxusercontent.com/u/40949268/emcc/AngryBots-fullscreen-nointeraction/index.html
 1. Press the fullscreen button in the bottom right corner to go fullscreen.
 2. Press the 'E' button on the keyboard to programmatically go back.

First one is a plain Emscripten page without Unity3D, second one is Unity3D AngryBots modified. I could not reproduce the issue in either case. There must be something else to the equation than this. It would be good to have a repro from the author.
Oh actually, I can now reproduce it in the AngryBots test case in Firefox 38. It does not always occur, perhaps on 1/5 attempts, here's the STR that would give it most consistently:

0. Have the browser window in windowed mode on the desktop, instead of maximized to covering the full desktop.
1. Navigate to https://dl.dropboxusercontent.com/u/40949268/emcc/AngryBots-fullscreen-nointeraction/index.html
2. After the page loads, press the Fullscreen button in the right corner.
3. Press Esc to exit fullscreen and go back to windowed mode.
4. Press Fullscreen button again.
5. Press 'E' to exit fullscreen.

Observed: After the last step, the page background is not cleared to white, but a still screenshot of the page is displayed behind the canvas.

I can't reproduce it in current FF 41 Nightly though, so there is a chance it has been fixed at some point.
When the issue does occur in Firefox 38, resizing the browser window from the corner by one pixel to force a repaint of the window client area makes the "ghost" image disappear, so this looks like some kind of a missed repaint in FF 38 when transitioning back.
Jukka, anything errors listed in about:support graphics section when this happens?
Whiteboard: [games] → [games][gfx-noted]
(In reply to Jukka Jylänki from comment #2)
> I can't reproduce it in current FF 41 Nightly though, so there is a chance
> it has been fixed at some point.

Can you find a fix window using mozregression?
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.