Checkerboarding on voetbalzone.nl during load

RESOLVED DUPLICATE of bug 1256677

Status

()

RESOLVED DUPLICATE of bug 1256677
3 years ago
3 years ago

People

(Reporter: janjongboom, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(1 attachment)

Didn't really know where to fit this. Running Nightly (June 18, 2015) with e10s enabled and Flash disabled (activate on click stuff) this page: http://www.voetbalzone.nl/doc.asp?uid=248358 is janky while scrolling with the touchpad on OSX. Especially directly after loading.

I disabled all installed Add-ons, except for Valence and Firefox Plug-n-hack, which I think are part of Firefox now?

Running OS/X 10.10 on a MBP Retina with Core i7 and 16 GB RAM. Same page in Safari is butter smooth.
It's janky for me during loading but scrolls smoothly afterwards. Can you get a performance profile by following these instructions? https://developer.mozilla.org/en-US/docs/Performance/Reporting_a_Performance_Problem
(Reporter)

Updated

3 years ago
Flags: needinfo?(janjongboom)
How are we supposed to run perf profiles these days now that we can't load unverified extensions?

https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem
Flags: needinfo?(janjongboom) → needinfo?(mstange)
For now, by disabling the check, but I think Benoit is working on getting the extension signed.
Flags: needinfo?(mstange) → needinfo?(bgirard)
See bug 1190972, waiting on the review.
Flags: needinfo?(bgirard)

Comment 5

3 years ago
I can't reproduce this on current nightly because of APZ, but instead I get checkerboarding. Profiles don't really help with that. Kats, is there something else I can do to help figure out what's going on here?
Flags: needinfo?(bugmail.mozilla)

Comment 6

3 years ago
(In reply to :Gijs Kruitbosch from comment #5)
> I can't reproduce this on current nightly because of APZ, but instead I get
> checkerboarding.

Well, more specifically, I get intermittent white patches showing up, not sure if that is exactly the same...
(In reply to :Gijs Kruitbosch from comment #5)
> I can't reproduce this on current nightly because of APZ, but instead I get
> checkerboarding. Profiles don't really help with that. Kats, is there
> something else I can do to help figure out what's going on here?

Profiles would still help because it would tell us what the main thread is doing while we're trying to scroll. However if the scrolling isn't janky and you're seeing checkerboarding instead then that's basically the intended effect of APZ, and I would consider this bug "fixed".

Note also that if you *are* seeing checkerboarding that's severe, you can go to about:checkerboard (Nightly only) and grab the raw log corresponding to the checkerboarding event from the textarea at the bottom of the page. That will give us some useful information as well like paint times and scroll velocity which can help us tune the code to reduce checkerboarding.
Flags: needinfo?(bugmail.mozilla)

Comment 8

3 years ago
Created attachment 8715854 [details]
Checkerboard-log

I don't know if this is "severe" or helpful or not... but this is what I get from about:checkerboard.
Flags: needinfo?(bugmail.mozilla)
That's fairly severe, thanks - the log says it was severity 26569 which based on telemetry data is somewhere close to the 90th percentile, so top 10%. The paint times are upwards of 500ms which is also pretty bad. Moving this to the APZ component for eventual further analysis.
Blocks: 1013364, 1154825
Component: General → Panning and Zooming
Flags: needinfo?(bugmail.mozilla)
Product: Firefox → Core
Summary: Scrolling janky on voetbalzone.nl → Checkerboarding on voetbalzone.nl during load
Keywords: polish
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256677
You need to log in before you can comment on or make changes to this bug.