Updating to 0.36 has warning and error

RESOLVED WONTFIX

Status

Testing
mozregression
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Elbart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8624670 [details]
mozregression_0.36_update.txt

Updated to 0.36 from 0.30, and the log showed two warnings/errors:

>Running lockfile-0.10.2\setup.py -q bdist_egg --dist-dir c:\users\user\appdata\l
ocal\temp\easy_install-f7oavv\lockfile-0.10.2\egg-dist-tmp-qp9s2_
>c:\mozilla-build\python\lib\site-packages\setuptools-12.0.5-py2.7.egg\pkg_resour
ces\__init__.py:2510: PEP440Warning: 'pbr (0.5.2.5.g5b3e942)' is being parsed as
 a legacy, non PEP 440, version. You may find odd behavior and sort order. In pa
rticular it will be sorted as less than 0.0. It is recommend to migrate to PEP 4
40 compatible versions.

and

>Installed c:\mozilla-build\python\lib\site-packages\mozlog-2.11-py2.7.egg
error: mozdevice 0.43 is installed but mozdevice>=0.44 is required by set(['mozv
ersion'])

Full log is attached.
Hmm, this is strange. First thing, you should use pip instead of easy_install - maybe that will resolve your issue ?

Install instructions:
http://mozilla.github.io/mozregression/install.html#mozregression

If you don't have pip, it is easy to install:
https://pip.pypa.io/en/latest/installing.html#install-pip

Please tell me how it goes with pip.
(Reporter)

Comment 2

3 years ago
Created attachment 8624715 [details]
pip.txt

(In reply to Julien Pagès from comment #1)
> Hmm, this is strange. First thing, you should use pip instead of
> easy_install - maybe that will resolve your issue ?
> 
> Install instructions:
> http://mozilla.github.io/mozregression/install.html#mozregression
> 
> If you don't have pip, it is easy to install:
> https://pip.pypa.io/en/latest/installing.html#install-pip
> 
> Please tell me how it goes with pip.

I used pip on another machine to update from 0.31 to 0.36, which worked, but running mozregression only gave an error:

$ mozregression --bits=32 --persist /k/fx -g 2012-01-01 --repo ux
Traceback (most recent call last):
  File "c:\mozilla-build\python\Scripts\mozregression-script.py", line 5, in <mo
dule>
    from pkg_resources import load_entry_point
  File "c:\mozilla-build\python\lib\site-packages\setuptools-0.6c11-py2.7.egg\pk
g_resources.py", line 2603, in <module>
  File "c:\mozilla-build\python\lib\site-packages\setuptools-0.6c11-py2.7.egg\pk
g_resources.py", line 666, in require
  File "c:\mozilla-build\python\lib\site-packages\setuptools-0.6c11-py2.7.egg\pk
g_resources.py", line 565, in resolve
pkg_resources.DistributionNotFound: futures>=2.1.6

Running easy_install -U mozregression after that error fixed that problem.
Unfortunately this really looks like a pip/easy_install issue. I don't see what was wrong with our dependencies in the setup.py file...

Something related, just before 0.39 release we updated all mozbase dependencies:

https://github.com/mozilla/mozregression/commit/7ba2c0b214acfd50cd13e9a861e8dcaa79b39228

Well I don't see what to do here, and can't reproduce it. Closing this as wontfix as I don't think we can do much.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.