Closed Bug 1176205 Opened 4 years ago Closed 4 years ago

Set browser.urlbar.suggest.searches to false on aurora

Categories

(Firefox :: Search, defect, P1, major)

41 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 42
Iteration:
41.3 - Jun 29
Tracking Status
firefox41 --- verified

People

(Reporter: kev, Assigned: mossop)

References

Details

(Whiteboard: [fxsearch][searchsuggestions][Bugday-20150701])

Attachments

(2 files, 2 obsolete files)

The current search suggests in the location bar is incomplete, and should be preffed off as development work and testing continues. Could we set the browser.urlbar.suggest.searches pref to false by default, instead of true and land it?
Version: 40 Branch → 41 Branch
Also, to add more clarity, this pref should be in place for when we merge with Aurora so it's turned off by default unless it's feature-complete in channel >= Aurora.
Assignee: nobody → dtownsend
Iteration: --- → 41.3 - Jun 29
Rank: 4
Flags: firefox-backlog+
Priority: -- → P1
Attached patch patch (obsolete) — Splinter Review
This disables search suggestions by default and hides the preference on non-nightly builds.
Attached patch patch (obsolete) — Splinter Review
For reference Drew we're considering the possibility of turning this off on nightly until bug 959567 is completed. Can you give this a review then I can land it if we decide to do that without waiting around.
Attachment #8624858 - Attachment is obsolete: true
Attachment #8624936 - Flags: review?(adw)
Comment on attachment 8624936 [details] [diff] [review]
patch

Review of attachment 8624936 [details] [diff] [review]:
-----------------------------------------------------------------

Sure.
Attachment #8624936 - Flags: review?(adw) → review+
Blocks: 958204
Attached patch patchSplinter Review
One minor change here, default suggestions to on in nightly and off elsewhere.
Attachment #8624936 - Attachment is obsolete: true
Attachment #8625794 - Flags: review?(adw)
Summary: Set browser.urlbar.suggest.searches to false → Set browser.urlbar.suggest.searches to false on aurora
Comment on attachment 8625794 [details] [diff] [review]
patch

Review of attachment 8625794 [details] [diff] [review]:
-----------------------------------------------------------------

that small change doesn't need further review, rs=me on that, just land it
Attachment #8625794 - Flags: review?(adw)
Attached patch patchSplinter Review
Turns out the privacy pane tests aren't reverting preference changes correctly. browser.urlbar.suggest.searches defaults to true but then is set to false by the testing harness, when the privacy pane tests clear user preferences they revert back to the default not to the test harness setting.

This instead caches the value of prefs before tests run and then revert to those at the end.
Attachment #8626009 - Flags: review?(mak77)
Attachment #8626009 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/bca014d5508a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Disabled the test on aurora for now until Mossop can look at it

https://hg.mozilla.org/releases/mozilla-aurora/rev/633cc765aa62
Flags: needinfo?(dtownsend)
Fixed the silly typo in the tests.
Flags: needinfo?(dtownsend)
Target Milestone: Firefox 41 → Firefox 42
I have successfully reproduced the bug in Nightly 41.0a1 (2015-06-19)(Build ID:20150619030204) with the instruction from comment 0 and windows 7 (32 bit) 
 
Mozilla/5.0 (Windows NT 6.1; rv:41.0) Gecko/20100101 Firefox/41.0

Verified as fixed with latest aurora 40.0a2 (2015-06-29)(Build ID: 20150629004008)

Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

Bugday-20150701]
Reproduced this bug in Latest Nightly 41.0a1 (2015-06-19) with the instruction from comment 0 and on Linux x64

Build ID: 20150619030204
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0


The bug is fixed on Latest Nightly 42.0a1 (2015-06-30) 

Build ID: 20150701030207
Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
QA Whiteboard: [Bugday-20150701]
Whiteboard: [fxsearch][searchsuggestions] → [fxsearch][searchsuggestions][Bugday-20150701]
Reproduced the bug in aurora 40.0a2 (Build ID 20150619004003) (User Agent Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0)

The bug is fixed on latest aurora 41.0a2 (Build ID 20150629134017) (User Agent Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0)

Also in latest nightly 42.0a1 (Build ID 20150701030207) (User Agent Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0)

As it is also verified on linux based on comment 17, changing the status as verified.
Status: RESOLVED → VERIFIED
Please enter the search icon on the gray bar. Like in searchbox.
http://zapodaj.net/images/ec579dbcd2f86.png
(In reply to look997 from comment #19)
> Please enter the search icon on the gray bar. Like in searchbox.
> http://zapodaj.net/images/ec579dbcd2f86.png

I think you are looking for bug 1180944.
You need to log in before you can comment on or make changes to this bug.