[e10s] Tab navigation gets stuck

RESOLVED FIXED in Firefox 42

Status

()

Core
DOM: Events
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Neil Deakin, Assigned: Neil Deakin)

Tracking

unspecified
mozilla42
Points:
3
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(e10s+, firefox42 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
1. Open:
  data:text/html,<input>
2. Press Tab a few times.

Expected: focus shifts from the urlbar, searchbar, document, input, then loops back to the urlbar

Actual: after focusing the document, tab navigation gets stuck and the tab key doesn't do anything

You can fix it by clicking elsewhere. It also works fine when navigating backwards with Shift+Tab.
(Assignee)

Comment 1

3 years ago
Created attachment 8624811 [details] [diff] [review]
Work in progress patch
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Blocks: 1163002
(Assignee)

Updated

2 years ago
Depends on: 1132518
tracking-e10s: --- → +
(Assignee)

Updated

2 years ago
Points: --- → 3
(Assignee)

Comment 2

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a7243bb5881e
(Assignee)

Comment 3

2 years ago
Created attachment 8634723 [details] [diff] [review]
Cleaned up patch

Currently, when tab navigation moves to a remote <browser>, it just focuses/activates it, leaving the focus at whatever was focused last time that <browser> was active. Instead, it should redirect the tab navigation to the child process to continue looking for the next element in tab order from its starting point (or ending point if navigating backwards)

This is easier now that the F6 navigation bug is done.
Attachment #8624811 - Attachment is obsolete: true
Attachment #8634723 - Flags: review?(bugs)
(Assignee)

Comment 4

2 years ago
Created attachment 8634725 [details] [diff] [review]
Test for this

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3876b62f498a
Attachment #8634725 - Flags: review?(bugs)

Comment 5

2 years ago
Comment on attachment 8634725 [details] [diff] [review]
Test for this

s/naviagtion/navigation/
Attachment #8634725 - Flags: review?(bugs) → review+

Comment 6

2 years ago
Comment on attachment 8634725 [details] [diff] [review]
Test for this

oh, wait, who calls add_task?
Attachment #8634725 - Flags: review+ → review?(bugs)

Comment 7

2 years ago
Comment on attachment 8634725 [details] [diff] [review]
Test for this

I guess add_task works that way. Couldn't find proper documentation though.
Attachment #8634725 - Flags: review?(bugs) → review+

Updated

2 years ago
Attachment #8634723 - Flags: review?(bugs) → review+
(Assignee)

Comment 8

2 years ago
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/f5ea755e3cb9b7fd2f56f7f453e5ea84512972c0
changeset:  f5ea755e3cb9b7fd2f56f7f453e5ea84512972c0
user:       Neil Deakin <neil@mozilla.com>
date:       Mon Jul 20 08:59:50 2015 -0400
description:
Bug 1176239, do tab navigation in the child when moving between the parent and child process, r=smaug

url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/bc18893041c1703ee837120497a919d8c3d1c40a
changeset:  bc18893041c1703ee837120497a919d8c3d1c40a
user:       Neil Deakin <neil@mozilla.com>
date:       Mon Jul 20 08:59:50 2015 -0400
description:
Bug 1176239, test e10s tab navigation between parent and child, r=smaug
https://hg.mozilla.org/mozilla-central/rev/f5ea755e3cb9
https://hg.mozilla.org/mozilla-central/rev/bc18893041c1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Hi, sorry had to back this out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=1844736&repo=mozilla-central
Status: RESOLVED → REOPENED
Flags: needinfo?(enndeakin)
Resolution: FIXED → ---

Comment 11

2 years ago
Backout:
https://hg.mozilla.org/mozilla-central/rev/9704aba173fd
https://hg.mozilla.org/mozilla-central/rev/d7a9e44717b7
(Assignee)

Comment 12

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=108c54818846
(Assignee)

Comment 13

2 years ago
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/7e72681dff59cb7f38dda53604a27d191a7a2e5f
changeset:  7e72681dff59cb7f38dda53604a27d191a7a2e5f
user:       Neil Deakin <neil@mozilla.com>
date:       Thu Jul 23 10:04:15 2015 -0400
description:
Bug 1176239, do tab navigation in the child when moving between the parent and child process, r=smaug
(Assignee)

Comment 14

2 years ago
I checked in the patch again without the test. I can't reproduce the failure but I'll keep looking.
Flags: needinfo?(enndeakin)
https://hg.mozilla.org/mozilla-central/rev/7e72681dff59
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Duplicate of this bug: 904865
You need to log in before you can comment on or make changes to this bug.