Closed Bug 1176277 Opened 5 years ago Closed 5 years ago

Text chat entries view should take up the whole height of the text chat view, when the input box isn't shown

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
3

Tracking

(firefox41 verified)

VERIFIED FIXED
mozilla41
Iteration:
41.3 - Jun 29
Tracking Status
firefox41 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(2 files)

Attached image Screen shot
See attached screenshot, currently when we've got the input box is disabled for text chat, the text entries view doesn't take up the additional height.
This fixes the issue - we now change the height if text chat is disabled for whatever reason.
Attachment #8624784 - Flags: review?(dmose)
Assignee: nobody → standard8
Iteration: --- → 41.3 - Jun 29
Comment on attachment 8624784 [details] [diff] [review]
Loop's text chat entries view should take up the whole height of the text chat view, when the input box isn't shown.

Review of attachment 8624784 [details] [diff] [review]:
-----------------------------------------------------------------

r=dmose, with comments addressed as you see fit.

::: browser/components/loop/content/shared/css/conversation.css
@@ +1178,5 @@
>  
>  .media-wrapper > .text-chat-view > .text-chat-entries {
>    /* 40px is the height of .text-chat-box. */
>    height: calc(100% - 40px);
>  }

So is the root cause here that while text-chat-view itself flexes, it also has display: block, meaning that its children can't flex, so we end up doing these hand-calculations like the one above, and overrides like the one below?

@@ +1184,5 @@
> +.media-wrapper > .text-chat-disabled > .text-chat-entries {
> +  /* When text chat is disabled, the entries box should be 100% height. */
> +  height: 100%;
> +}
> +

Any particular reason this, and the next change, require the .media-wrapper part of this selector
Attachment #8624784 - Flags: review?(dmose) → review+
(In reply to Dan Mosedale (:dmose) - needinfo? me for response from comment #2)
> >  .media-wrapper > .text-chat-view > .text-chat-entries {
> >    /* 40px is the height of .text-chat-box. */
> >    height: calc(100% - 40px);
> >  }
> 
> So is the root cause here that while text-chat-view itself flexes, it also
> has display: block, meaning that its children can't flex, so we end up doing
> these hand-calculations like the one above, and overrides like the one below?

Yes. If it flexed, then it would flex out of the column and mess up everything unfortunately.

> @@ +1184,5 @@
> > +.media-wrapper > .text-chat-disabled > .text-chat-entries {
> > +  /* When text chat is disabled, the entries box should be 100% height. */
> > +  height: 100%;
> > +}
> 
> Any particular reason this, and the next change, require the .media-wrapper
> part of this selector

This is semi temporarily until we share the new media layout into new locations (e.g. desktop conversation window). When we do that, then we might need to alter these a bit.

I'll add a comment.
https://hg.mozilla.org/mozilla-central/rev/087915962252
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Flags: qe-verify+
QA Contact: bogdan.maris
I could not reproduce this issue on a old Nightly build (2015-06-19). Though I did some exploratory testing using Firefox 41.0 RC and did not encounter any issues. 
Mark could you please take a quick look at Firefox 41.0 RC to see if the issues is fixed?
Flags: needinfo?(standard8)
I think I may have actually filed this against standalone with narrow-widths, though it'd equally apply to the popped-out conversation window.

In any case, this does appear to be working correctly in both situations.
Status: RESOLVED → VERIFIED
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.