Closed Bug 1176328 Opened 5 years ago Closed 4 years ago

[Flame] Flickering could occur when bringing up Homescreen menus

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: pcheng, Unassigned)

References

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(1 file)

Attached file logcat of issue
Description:
On Flame 2.2, flickering occurs when bringing up the Homescreen related menus by long tapping an empty space within a collapsed smart collection group without scrolling down.

STR:
1) Flash to today's 2.2 Flame
2) Progress past FTU
3) On Homescreen, without scrolling down, tap to minimize the smart collections group
4) Long tap on the empty space within smart collections group

Expected: The Homescreen menu is brought up without flickering

Actual: The Homescreen menu is brought up with flickering, and when hitting Cancel it flickers too.

The video can't very well capture the flickering:
https://www.youtube.com/watch?v=zWoNYlH8B84

Repro rate: 10/10 if following STR. The bug seems to no longer occur if I collapse the 3rd group of icons below smart collections, or scroll down to bottom of Homescreen.

Also attaching a logcat.

Device: Flame (KK, 319MB, full flashed)
BuildID: 20150619002501
Gaia: 1c33072e33c279c8aa5cb5e4a3e4da6af6cd818b
Gecko: 5ad34a170633
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flame 3.0 is unaffected.

Device: Flame 3.0
BuildID: 20150619010205
Gaia: a0df9c367a68764bdcf2e2e1c4d27f0d6ee165b8
Gecko: 2694ff2ace6a
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

----

Flame 2.1 doesn't have the app grouping feature implemented, and bug doesn't occur.

Device: Flame 2.1
BuildID: 20150619001206
Gaia: f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gecko: ed778b596fad
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---

It is highly likely this is a regression within 2.2 branch, but not adding regression keyword until it's been proven.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [3.0-Daily-Testing][systemsfe]
This is most definitely a regression and completely unrelated to app-grouping (except possibly tangentially if it's a gfx issue). I expect this to be a Gecko bug, let's get a window.
QA Contact: jthomas
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This issue seems to be on User specific builds. I was not seeing it on Engineering builds. I was also seeing this issue occurring all throughout 2.2.

Mozilla Inbound Regression Window

First Broken 

Environmental Variables:
Device: Flame 3.0 Shallow Flash (319mb)
BuildID: 20150402013006
Gaia: fb7414fa6f5dbb898adc5bd2bbd9fb75df0d0054
Gecko: 17068af9fd15
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Working

Environmental Variables
Device: Flame 3.0 Shallow Flash (319mb)
BuildID: 20150402133009
Gaia: 62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gecko: 05c0b5cfe341
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0



First Working gaia / Last Broken gecko - This issue DOES occur.
Gaia: 62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gecko: 17068af9fd15

Last Broken gaia / First Working gecko - This issue does occur.
Gaia: fb7414fa6f5dbb898adc5bd2bbd9fb75df0d0054
Gecko: 05c0b5cfe341

Mozilla Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=17068af9fd15&tochange=05c0b5cfe341


This issue most likely occurs due to  Bug 1148855
Blocks: 1148855
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
The window listed above should noted that it is a reverse regression window.
Markus, can you take a look at this please? Can we get the fix for Bug 1148855 uplifted to 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(mstange)
Uplifting bug 1148855 is not an option.

I guess I could try to debug it, but I'm not sure that's very valuable.
Flags: needinfo?(mstange)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.