Closed Bug 1176335 Opened 6 years ago Closed 6 years ago

[Aries][Camera] Video Recording from Rear-Facing Camera puts audio out of sync

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-master unaffected)

RESOLVED WORKSFORME
Tracking Status
b2g-master --- unaffected

People

(Reporter: onelson, Unassigned)

References

()

Details

(Keywords: smoketest, Whiteboard: [3.0-Daily-Testing], [Spark])

Description:
When the video records a from with the rear facing camera on Aries devices, they will observe the audio fall out of sync. This DOES NOT OCCUR with the front facing camera, and an interesting distinction that could be wrought is the rearfacing camera records much larger video sizes, which may contribute to how this sync falls out.


Repro Steps:
1) Update a Aries to 20150619021036
2) Open the Camera app
3) Record a video (rear-facing camera)
4) Watch video, listening for audio and matching with video

Actual:
Audio falls out of sync with video

Expected:
Audio remains in sync with video


Environmental Variables:
----------------------------------

Device: Aries 3.0
Build ID: 20150619021036
Gaia: fcce826ab790d074e88e055ae7f2ab4fb0f01903
Gecko: 8a8307ba002f07c6a36668c65f6f39083bd30703
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
*************************

Issue DOES NOT REPRO on flame devices
Results: Audio remains in sync with video

Device: Flame 3.0
BuildID: 20150619010205
Gaia: a0df9c367a68764bdcf2e2e1c4d27f0d6ee165b8
Gecko: 2694ff2ace6a
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
----------------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/6dvIiTqE_Mk
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: smoketest
[Blocking Requested - why for this release]:
issue failing smoke tests.
blocking-b2g: --- → spark?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QAWanted to see if this was a regression on Spark
This issue may be related to bug 1171257.  On all Frozen for the workweek builds I am able to reproduce this issue, however on the latest non frozen Aries build I have this issue doesn't occur but bug 1171257 does.  

This occurs on the earliest available Frozen for the workweek build and the latest available non frozen build.

Earliest Frozen Environmental Variables:
Device: Aries 3.0
BuildID: 20150616191346
Gaia: 62ba52866f4e5ca9120dad5bfe62fc5df981dc39
Gecko: e5b377d09c2edea6b42e74a9f072b642053f0171
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Latest available non-frozen Environmental Variables:
Device: Aries 3.0
BuildID: 20150618135420
Gaia: c3f8a3346787c0fcb61775769f559540e253e6bf
Gecko: efe86609e776
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Issue still occurs on build mentioned in comment 4 by Naoki:
Results: Audio is out of sync from rear-facing camera recorded videos

--------------------------------------------------
Environmental Variables:
Device: Aries 3.0
BuildID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
--------------------------------------------------
Repro: 4/4
Flags: needinfo?(onelson) → needinfo?(nhirata.bugzilla)
blocking-b2g: spark? → 2.5?
Flags: needinfo?(pbylenga)
Smoketest team has not encountered this issue recently, including today's spark smoketest.  Resolving as WorksForMe.  Please reopen if the issue occurs again.
Recorded video does not display any significant audio sync issues.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150709163506
Gaia: fc6643dd3da2ccdf2ab284479643836bb3698644
Gecko: d656ef3c4936
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: NEW → RESOLVED
Closed: 6 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Flags: needinfo?(nhirata.bugzilla)
blocking-b2g: 2.5? → ---
Duplicate of this bug: 1180318
You need to log in before you can comment on or make changes to this bug.