Intermittent browser_timeline-filters-01.js | Found at least one 'Unknown' marker or Found at least one 'Reflow' marker (1)

RESOLVED FIXED in Firefox 41

Status

defect
RESOLVED FIXED
4 years ago
Last year

People

(Reporter: RyanVM, Assigned: vporof)

Tracking

({intermittent-failure})

unspecified
Firefox 42
x86
Windows 7
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox40 unaffected, firefox41 fixed, firefox42 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

16:47:30 INFO - 5918 INFO TEST-START | browser/devtools/performance/test/browser_timeline-filters-01.js
16:47:32 INFO - 5919 INFO checking window state
16:47:32 INFO - 5920 INFO Initializing a performance pane.
16:47:32 INFO - 5921 INFO Adding tab: http://example.com/browser/browser/devtools/performance/test/doc_simple-test.html
16:47:32 INFO - 5922 INFO Tab added and finished loading: http://example.com/browser/browser/devtools/performance/test/doc_simple-test.html
16:47:32 INFO - 5923 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be checked yet.
16:47:32 INFO - 5924 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be locked yet.
16:47:32 INFO - 5925 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should now be checked.
16:47:32 INFO - 5926 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should be locked.
16:47:32 INFO - 5927 INFO Waiting for event: 'Performance:UI:StateChanged' on [object PerformanceView]
16:47:32 INFO - 5928 INFO Received event: 'Performance:UI:StateChanged' on [object PerformanceView]
16:47:32 INFO - 5929 INFO Waiting for event: 'Performance:UI:OverviewRendered' on [object OverviewView]
16:47:32 INFO - 5930 INFO Received event: 'Performance:UI:OverviewRendered' on [object OverviewView]
16:47:32 INFO - 5931 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The current state is 'recording'.
16:47:32 INFO - 5932 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should still be checked.
16:47:32 INFO - 5933 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be locked.
16:47:32 INFO - 5934 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Recording has started.
16:47:32 INFO - 5935 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should already be checked.
16:47:32 INFO - 5936 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be locked yet.
16:47:32 INFO - 5937 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be checked.
16:47:32 INFO - 5938 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should be locked.
16:47:32 INFO - 5939 INFO Waiting for event: 'Performance:UI:StateChanged' on [object PerformanceView]
16:47:32 INFO - 5940 INFO Received event: 'Performance:UI:StateChanged' on [object PerformanceView]
16:47:32 INFO - 5941 INFO Waiting for event: 'Performance:UI:OverviewRendered' on [object OverviewView]
16:47:32 INFO - 5942 INFO Received event: 'Performance:UI:OverviewRendered' on [object OverviewView]
16:47:32 INFO - 5943 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The current state is 'recorded'.
16:47:32 INFO - 5944 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be checked.
16:47:32 INFO - 5945 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | The record button should not be locked.
16:47:32 INFO - 5946 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Styles' marker (1)
16:47:32 INFO - 5947 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Reflow' marker (1)
16:47:32 INFO - 5948 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Paint' marker (1)
16:47:32 INFO - 5949 INFO TEST-UNEXPECTED-FAIL | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Unknown' marker (1) -
16:47:32 INFO - Stack trace:
16:47:32 INFO - chrome://mochitests/content/browser/browser/devtools/performance/test/browser_timeline-filters-01.js:spawnTest:56
16:47:32 INFO - self-hosted:InterpretGeneratorResume:715
16:47:32 INFO - self-hosted:next:623
16:47:32 INFO - test@chrome://mochitests/content/browser/browser/devtools/performance/test/head.js:173:3
16:47:32 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:770:9
16:47:32 INFO - Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:664:7
16:47:32 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:746:59
16:47:32 INFO - 5950 INFO Waiting for event: 'command' on [object XULElement]
16:47:32 INFO - 5951 INFO Received event: 'command' on [object XULElement]
16:47:32 INFO - 5952 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Overview height hasn't changed
16:47:32 INFO - 5953 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Styles' marker (2)
16:47:32 INFO - 5954 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Reflow' marker (2)
16:47:32 INFO - 5955 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Paint' marker (2)
16:47:32 INFO - 5956 INFO TEST-UNEXPECTED-FAIL | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Unknown' marker (2) -
16:47:32 INFO - Stack trace:
16:47:32 INFO - chrome://mochitests/content/browser/browser/devtools/performance/test/browser_timeline-filters-01.js:spawnTest:66
16:47:32 INFO - self-hosted:InterpretGeneratorResume:715
16:47:32 INFO - self-hosted:next:623
16:47:32 INFO - test@chrome://mochitests/content/browser/browser/devtools/performance/test/head.js:173:3
16:47:32 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:770:9
16:47:32 INFO - Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:664:7
16:47:32 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:746:59
16:47:32 INFO - 5957 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5958 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5959 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Overview height hasn't changed
16:47:33 INFO - 5960 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Styles' marker (3)
16:47:33 INFO - 5961 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Reflow' marker (3)
16:47:33 INFO - 5962 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Paint' marker (3)
16:47:33 INFO - 5963 INFO TEST-UNEXPECTED-FAIL | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Unknown' marker (3) -
16:47:33 INFO - Stack trace:
16:47:33 INFO - chrome://mochitests/content/browser/browser/devtools/performance/test/browser_timeline-filters-01.js:spawnTest:76
16:47:33 INFO - self-hosted:InterpretGeneratorResume:715
16:47:33 INFO - self-hosted:next:623
16:47:33 INFO - test@chrome://mochitests/content/browser/browser/devtools/performance/test/head.js:173:3
16:47:33 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:770:9
16:47:33 INFO - Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:664:7
16:47:33 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:746:59
16:47:33 INFO - 5964 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5965 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5966 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Overview is smaller
16:47:33 INFO - 5967 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Styles' marker (4)
16:47:33 INFO - 5968 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Reflow' marker (4)
16:47:33 INFO - 5969 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Paint' marker (4)
16:47:33 INFO - 5970 INFO TEST-UNEXPECTED-FAIL | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Unknown' marker (4) -
16:47:33 INFO - Stack trace:
16:47:33 INFO - chrome://mochitests/content/browser/browser/devtools/performance/test/browser_timeline-filters-01.js:spawnTest:86
16:47:33 INFO - self-hosted:InterpretGeneratorResume:715
16:47:33 INFO - self-hosted:next:623
16:47:33 INFO - test@chrome://mochitests/content/browser/browser/devtools/performance/test/head.js:173:3
16:47:33 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:770:9
16:47:33 INFO - Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:664:7
16:47:33 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:746:59
16:47:33 INFO - 5971 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5972 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5973 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Styles' marker (5)
16:47:33 INFO - 5974 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Reflow' marker (5)
16:47:33 INFO - 5975 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Paint' marker (5)
16:47:33 INFO - 5976 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Unknown' marker (5)
16:47:33 INFO - 5977 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5978 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5979 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5980 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5981 INFO Waiting for event: 'command' on [object XULElement]
16:47:33 INFO - 5982 INFO Received event: 'command' on [object XULElement]
16:47:33 INFO - 5983 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Styles' marker (6)
16:47:33 INFO - 5984 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Reflow' marker (6)
16:47:33 INFO - 5985 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Found at least one 'Paint' marker (6)
16:47:33 INFO - 5986 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | No 'Unknown' marker (6)
16:47:33 INFO - 5987 INFO TEST-PASS | browser/devtools/performance/test/browser_timeline-filters-01.js | Overview restored
16:47:33 INFO - 5988 INFO Destroying the performance tool.
16:47:33 INFO - JavaScript error: chrome://browser/content/devtools/performance/views/details-waterfall.js, line 134: TypeError: this._cache is null
16:47:33 INFO - 5989 INFO Console message: [JavaScript Error: "TypeError: this._cache is null" {file: "chrome://browser/content/devtools/performance/views/details-waterfall.js" line: 134}]
16:47:33 INFO - 5990 INFO Removing tab.
16:47:33 INFO - 5991 INFO Tab removed and finished closing.
16:47:33 INFO - ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
16:47:33 INFO - ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
16:47:33 INFO - 5992 INFO finish() was called, cleaning up...
16:47:33 INFO - MEMORY STAT | vsize 672MB | vsizeMaxContiguous 598MB | residentFast 203MB | heapAllocated 66MB
16:47:33 INFO - 5993 INFO TEST-OK | browser/devtools/performance/test/browser_timeline-filters-01.js | took 2800ms
Summary: Intermittent browser_timeline-filters-01.js | Found at least one 'Unknown' marker → Intermittent browser_timeline-filters-01.js | Found at least one 'Unknown' marker or Found at least one 'Reflow' marker (1)
Duplicate of this bug: 1184128
Any idea what's going on here, Victor?
Flags: needinfo?(vporof)
Looking into it, but I suspect it's the same issue as bug 1161817 where the data source is completely different from what is displayed in the waterfall for some reason. Best is to disable this test for now until I have time to properly bisect it.
Flags: needinfo?(vporof)
https://hg.mozilla.org/mozilla-central/rev/84f8446d5a5d
Assignee: nobody → vporof
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.