“ and ” don't display quotes as expected




16 years ago
16 years ago


(Reporter: Biesinger, Assigned: Shanjian Li)



Firefox Tracking Flags

(Not tracked)




(4 attachments, 1 obsolete attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20011213
BuildID:    2001123022 (self-compiled)

In the URL mentioned above there's a text "There's not enough room ...". Around
foopy.sit and c: should be curly quotes, according to mpt.

But, “ is displayed as ´ and ” is displayed as a character similar
to a ; or an i.

Reproducible: Always
Steps to Reproduce:
1. Visit above URL
2. Maybe scroll down a bit
3. Look at wrongly displayed characters

This is on Mandrake Linux 8.1. Also occurs with nightly build 2001123121

Comment 1

16 years ago
Using Mandrake Cooker the quotes look fine to me. In Appearance->Fonts I use the
adobe fonts (adobe-times, adobe-helvetica, adobe-courier).
ok... using the adobe fonts, it works as expected. I was using monotype-times
new roman, monotype-arial and monotype-courier new; which look much better (I
think these are truetype fonts that I copied from my windows installation).

Still, shouldn't Mozilla display the correct symbols even with these fonts?
Brian, would you take this?  Or should this just got to I18N?

Comment 4

16 years ago
-> ftang
Assignee: attinasi → ftang

Comment 5

16 years ago
per ftang: --> shanjian
Assignee: ftang → shanjian

Comment 6

16 years ago
mozilla could not check a font's glyph and tell which one is better. But 
we do allow user to choose the right font. Isn't that enough?
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
So, there is nothing I can do to get a correct character display with this font?
It looks much nicer than adobe-times.

Comment 8

16 years ago
Because moz's font display is fairly complex I recommend we get the user to 
dislay font in a separate (very simple) program. This way we can verify that 
the font is actually wrong. 

Is there a way to get xfd to display these chars?

I'm reopening this so we can verify the font has a problem.
Resolution: WORKSFORME → ---

Comment 9

16 years ago
Created attachment 64422 [details]
test case

Comment 10

16 years ago
Created attachment 64423 [details]
display on my RedHat 7.2 J system. Look normal- ascii transliteration by unicode compat mapping

Comment 11

16 years ago
“ is U+201c ( LEFT DOUBLE QUOTATION MARK -> 0022 qutionat mark) and 
 ” is U+201d ( RIGHT DOUBLE QUOTATION MARK -> 0022 qutionat mark) 

Comment 12

16 years ago
I cannot reproduce your problem (see my screen shot). can you include a screen shot?
Created attachment 64657 [details]
Screenshot of testcase

Here is the requested screenshot

Comment 14

16 years ago
Shanjian: you'll need to find out what font are being loaded and then
find out which font the glyphs are coming from

Comment 15

16 years ago
Christian, could you set environtment variable "NS_FONT_DEBUg" to be 5, and then
post the output in console? That will allow us to identify which font is used
for these 2 chars.  thanks.
Created attachment 67954 [details]
Console Output

This is all the output, starting from when I loaded the page. Do you want the
earlier output as well?

Comment 17

16 years ago
Christian, are you sure that is the right output? I didn't see mozilla resolving
glyph for u+201c, u+201d. It is trying for u+2014, u+2026. Could you set this
test page for you home page temporily and start mozilla.  Then post everything
you got in you output screen. thanks.
Created attachment 67978 [details]
Console Output 2

I noticed now that the page has changed, which may be the reason for the
character to not appear...

I have now set the testcase of this bug as the homepage; here's the output.
Attachment #67954 - Attachment is obsolete: true
I just noticed another thing: The character ’, which should presumably
display as ' also displays wrongly for me (it's displayed as a y with two dots
above it, like this: ’)

(8217 = 0x2019; which is part of the original console output, afaict)

Comment 20

16 years ago
I was wondering the problem might be caused by bad fonts. iso8859-13 charset
contains u+201c and u+201d. To confirm this is not a generic problem for all
iso8859-13 fonts, I download some iso8859-13 fonts from
"http://bibliofile.mc.duke.edu/gww/fonts/Caslon/Caslon.html". I verified the
fonts works well in my browser. 

Is it possible for you to grab some kind of font viewer to check the glyph for
those 2 chars? Other options include specifying a difference font in your font
preference setting (Edit->Preference->Appearance->fonts) other than
"monotype-times new roman-iso8859-1". That will only work if you have other
8859-13 fonts available. Temporarily remove those font in you font directory
should work if you have no other choice. 

Comment 21

16 years ago
use 'xfontset' to figure out the XLFD font name and then use 
'xfd -fn <fontname>' to display it.
OK, I found this: (I used the iso8859-13 version of monotype-times new roman, I
hope that was correct)

The character that I would expect (the Quotation Mark ") is at position 0x22
The characters that get displayed are at position 0xa1 (”) (for U+201d) and 0xb4
(“) (for U+201C)

And for &#8217;: The character at 0xff is used, while 0x27 is correct (afaict)

I hope this is the information that you wanted
I have also tried a few other fonts, of which I have the iso8859-13 version. 
Tbe following fonts also displayed the character wrong (in the same way, btw):
bitstream-bitstream cyberbit
linotype-palatino linotype
(maybe others, I haven't tried all that I have)

Comment 24

16 years ago
As Shanjian Li indicates, this is almost certainly a font problem, and not a bug
in Mozilla.  More information is available in a Usenet discussion and in Debian
bug report #141571: 

Tristan, thanks for the links. marking INVALID.
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.