Font-family seems to be ignored on some sites

VERIFIED WORKSFORME

Status

()

Core
Layout: Text
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sean White, Unassigned)

Tracking

({fonts})

41 Branch
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8625036 [details]
Screenshot from 2015-06-20 19-11-39.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150616142847

Steps to reproduce:

On some sites that have font-family set in their CSS firefox ignores the fonts and goes straight to the sans-serif font despite the other being installed.  As a testing site I will provide this link http://archiveofourown.org/ .

I'm running Archlinux but Firefox is the only program affected.
(Reporter)

Comment 1

3 years ago
The Screenshot shows the difference between the chrome and firefox rendering

Comment 2

3 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
20150619030204

Lucida Grande, Lucida Sans Unicode, Verdana, Helvetica.

Do you have any of the above installed on your system? I checked my Linux Mint KDE 17.1 installation and they're not included by default. Firefox uses my default sans-serif font, as expected.

font-weight: 100 is also specified, which is why an “extra light” font is used in your case (I don't have any installed).
Component: Untriaged → Layout: Text
Keywords: fonts
Product: Firefox → Core
This might be the same underlying issue as bug 1174946; if so, the fix just landed on inbound, so it should show up in Nightly within a day or two.
(Reporter)

Comment 4

3 years ago
In the case of the site I linked I have all the fonts that are actually listed installed.  I shall monitor that linked bug and will update this one accordingly if it turns out that the fix for it fixes my issue.

Comment 5

3 years ago
(In reply to Sean White from comment #4)
> I shall monitor that linked bug and will update this one
> accordingly if it turns out that the fix for it fixes my issue.

Can you please test the latest Nightly now? You may want to start it in a brand new profile to avoid any changes to your default profile.
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(runicpaladin)
(Reporter)

Comment 6

3 years ago
Sorry, meant to mark this as fixed and got a little sidetracked.  Everything works now
Flags: needinfo?(runicpaladin)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.