Closed Bug 1176499 Opened 4 years ago Closed 4 years ago

Opening video hangs browser for some seconds

Categories

(Core :: Audio/Video, defect, major)

41 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla41
Tracking Status
firefox40 --- unaffected
firefox41 --- verified

People

(Reporter: Virtual, Assigned: kinetik)

References

(Blocks 1 open bug)

Details

(4 keywords, Whiteboard: [fixed by patch backout from bug #1103824])

Attachments

(3 files)

STR1:
1. Open https://www.youtube.com/watch?v=NRUBe2RTq74
2. Scroll down and up, when webpage is loading
3. Enjoy the hang

STR2:
1. Open attached movie in new tab
2. Try switching to other tab
3. You can't as browser is in hang state


Regression window (mozilla-inbound-win32)
Good:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1434428242/

Bad:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1434428360/

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=60fc51d40741&tochange=aeaa70495f1d

Caused by:
Bug 1103824 - Ensure first initialization of IAudioClient happens on STA thread. r=padenot


Profile taken with Gecko Profiler 1.16.1
http://people.mozilla.org/~bgirard/cleopatra/#report=faac36375fae00718f86ce4419b3712108e1e66e


[Tracking Requested - why for this release]: Regression
Flags: needinfo?(kinetik)
Don't see this on my configuration; I suspect this only happens on a subset of machines with a particular configuration.  Would you mind posting the following details:

- Result of running dxdiag.exe and clicking "Save All Information"
  (I only need the audio related bits, so feel free to delete anything else from the resulting txt file)
- In the Sound control panel, right click on the "Default Device", select Properties, select the Advanced tab, and let me know what the "Default Format" is set as.

Thanks!
Flags: needinfo?(kinetik)
A couple of other things I forgot to ask:

- Do you see this every time you play media, or only the first time after the browser is started?
- Can you please repeat your test using the set of files here: http://flim.org/~kinetik/tests/bug1176499/
  (it's a simple 5 second sine wave encoded in various sample formats)

Thanks!
Flags: needinfo?(BernesB)
(In reply to Matthew Gregan [:kinetik] from comment #1)
> - Result of running dxdiag.exe and clicking "Save All Information"
>   (I only need the audio related bits, so feel free to delete anything else
> from the resulting txt file)
See Comment 3 and Comment 4


my whole PC specs:
CPU: Intel Core 2 Duo E6550 2,33@3,4GHz (default voltage, energy savings options like CPU Enhanced Halt State [C1E] & CPU EIST Function [Enhanced Intel SpeedStep Technology] are disabled)
MOBO: Gigabyte GA-P35C-DS3R (latest BIOS version [F13d], FSB 333@481MHz, FSB:DRAM ratio 1:1, default voltages/timings/speeds, especially PCI-E blocked and locked at 100MHz)
RAM: Kingston HyperX (KHX8500D2K2) 4GB (2x 2GB) DDR2 1066MHz (1066@962MHz, DRAM:FSB ratio 1:1, default memory voltage=2,2V set manually)
GPU: Palit (NE5X4600HD09F) NVIDIA GeForce GTX 460 v2 1GB GDDR5 (GF114; 10DE-1205/0000-0000[Rev A1]) (778MHz/4008MHz, 192bit, BIOS version=70.24.25.00.00; PCIe 2.0x16@1.1x16 due to P35 limit) with 347.88 drivers (newest are bugged on my GPU and giving me constant TDR in every game)
SOUND: Creative Sound Blaster Live! 5.1 with kX drivers (ASIO) 5.10.0.3551
PSU: Corsair VX550W
LCD: LG Flatron W2252TQ (60@76MHz [CVT-R], 1680x1050, 32bit, 96 DPI, connected to GPU with DVI-D) [in repair - for backup using now Belinea 10 19 05 (75MHz [CVT], 1280x1024, 32bit, 96 DPI, connected to GPU with D-Sub)
HDD: Samsung HD103SJ (1TB) [system], Seagate ST3000DM001 (3TB), Samsung HD642JJ (640GB)
SYS: Microsoft Windows 7 Professional (64bit) [with SP1 + all patches, Aero is enabled]

more drivers info:
Chipset Software Installation Utility - 10.0.27 - drivers for motherboard
Rapid Storage Technology - 13.6.0.1002 - drivers for motherboard
LAN drivers - 7.092 - for integrated Realtek 8111B on motherboard



(In reply to Matthew Gregan [:kinetik] from comment #1)
> - In the Sound control panel, right click on the "Default Device", select
> Properties, select the Advanced tab, and let me know what the "Default
> Format" is set as.
2-channel, 16-bit, 48.000Hz (DVD Quality)



(In reply to Matthew Gregan [:kinetik] from comment #2)
> - Do you see this every time you play media, or only the first time after
> the browser is started?
I see this issue only the first time when I play the movie,
restarting browser make it occur again.
Sometimes is reproducible even without restart,
when delay between playing movies is very long.



(In reply to Matthew Gregan [:kinetik] from comment #2)
> - Can you please repeat your test using the set of files here:
> http://flim.org/~kinetik/tests/bug1176499/
>   (it's a simple 5 second sine wave encoded in various sample formats)
I can reproduce it on all samples. I tested only one sample and the next one after browser restart.
Adding a tracking flag for FF41.
Thanks for the additional debugging information.  I don't have an immediate solution, and since the change causing this was a speculative fix I've backed it out in bug 1103824 for now.
Virtual_ManPL, is this still an issue for you on latest Firefox41 (on Beta channel)? Thanks!
Flags: needinfo?(bernesb)
No, because patch which caused this issue was backed out per Bug 1103824 Comment 14 and Bug 1103824 Comment 15.
I will untrack Firefox 41 and also change its status.
Flags: needinfo?(bernesb)
Version: 41 Branch → Trunk
Merge of backout:
https://hg.mozilla.org/mozilla-central/rev/b10c59539ec8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Version: Trunk → 41 Branch
Whiteboard: [fixed by patch backout from bug #1103824]
You need to log in before you can comment on or make changes to this bug.