[e10s] crash in sse2_composite_src_x888_8888 with HWA disabled

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: over68, Assigned: bas.schouten)

Tracking

({crash, regression, topcrash-win})

41 Branch
x86_64
Windows 7
crash, regression, topcrash-win
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
The nightly build crash with hardware acceleration disabled.

Crash report: bp-3fd77e2a-e63d-4c52-a869-b84682150620
(Reporter)

Updated

4 years ago
Blocks: 1172014
(Reporter)

Updated

4 years ago
Crash Signature: [@ sse2_composite_src_x888_8888 ]
(Reporter)

Updated

4 years ago
Flags: needinfo?(bas)
(Reporter)

Updated

4 years ago
tracking-e10s: --- → ?
Component: Untriaged → Graphics: Layers
Product: Firefox → Core
Summary: [e10s] Crash in sse2_composite_src_x888_8888 → [e10s] crash in sse2_composite_src_x888_8888
(Reporter)

Updated

4 years ago
Keywords: regression
(Reporter)

Comment 2

4 years ago
The crash happens when start the browser with HWA disabled and enable e10s.

Comment 3

4 years ago
Also crashing on WinXP, not crashing in todays Aurora.

Steps to reproduce:
1. open about:crashes
2. load crash report

https://crash-stats.mozilla.com/report/index/bp-a8c30261-f72a-4aaa-911f-a9f1e2150621
Flags: needinfo?(bas)

Comment 5

4 years ago
Found it after create of a new clean profile. On clean profiles is E10s enabled and HWA off here. 

unexpected software exception 0x80000003 in plugin-container.exe at .....

Deleted Pluginreg.dat to get firefox to start and disabled E10s to fix this.

https://crash-stats.mozilla.com/report/index/8ff2f6b8-9881-437a-b695-b5fed2150621
Bas, Jeff, Milan: This bug has caused Nightly crash volume to go up 10x. Could you please take a look urgently? Thanks.
Flags: needinfo?(milan)
Flags: needinfo?(jmuizelaar)
This is a startup crash that has gone off the charts for Nightly builds of 41, 2015062003,  on Windows.
Keywords: crash, topcrash-win
(Assignee)

Comment 8

4 years ago
Very interesting, I wonder if nightly is having some sort of alignment issue on certain systems.. what's the OS breakdown here?
Assignee: nobody → bas
We can just back bug 1172014 out.
(Assignee)

Comment 10

4 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #9)
> We can just back bug 1172014 out.

Yeah, I'm fine with that too, although it would stop the supply of data, then again, we might already have the data we need.
Thanks Jeff. Last I checked the OS breakdown looked pretty typical.
Flags: needinfo?(milan)
Oh and it doesn't smell like alignment to me. A lot of the addresses end in 000 which makes me suspect a bad buffer where the read went off the end of a page.

Comment 14

4 years ago
https://crash-stats.mozilla.com/report/index/f2f2f24e-caa7-4080-9788-83a9b2150622
Summary: [e10s] crash in sse2_composite_src_x888_8888 → [e10s] crash in sse2_composite_src_x888_8888 with HWA disabled

Comment 15

4 years ago
worksforme now
not crashing since update to yesterdays nightly 41.0.0.5651 20150622052959
https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
FIXED per backout. So far no reports of this crash on Nightly build of 20150623.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
no more crashes with this signature on Nightly builds since the backout landed.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
tracking-e10s: ? → ---
You need to log in before you can comment on or make changes to this bug.