TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_predictor.js | Test timed out

RESOLVED FIXED in Firefox 41

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mkmelin, Assigned: mkmelin)

Tracking

({intermittent-failure, regression})

Trunk
mozilla42
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox41 fixed, firefox42 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/tinderbox-builds/comm-central-linux64/1434820484/comm-central_ubuntu64_vm_test-xpcshell-bm122-tests1-linux64-build1.txt.gz

From bug 959752.

10:20:03     INFO -  Retrying tests that failed when run in parallel.
10:20:03     INFO -  TEST-START | netwerk/test/unit/test_predictor.js
10:25:03  WARNING -  TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_predictor.js | Test timed out
10:25:03     INFO -  TEST-INFO took 300060ms
10:25:03     INFO -  >>>>>>>
10:25:03     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
10:25:03     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
10:25:03     INFO -  running event loop
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting reset_predictor
10:25:03     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (3)
10:25:03     INFO -  (xpcshell/head.js) | test reset_predictor finished (3)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting test_link_hover
10:25:03     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
10:25:03     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_link_hover - [test_link_hover : 76] true == true
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (3)
10:25:03     INFO -  (xpcshell/head.js) | test test_link_hover finished (3)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting test_pageload
10:25:03     INFO -  (xpcshell/head.js) | test test_pageload pending (2)
10:25:03     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_pageload - [test_pageload : 140] 0 == 0
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 2 finished (2)
10:25:03     INFO -  <<<<<<<
10:25:03     INFO -  xpcshell return code: None
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Process still running after test!
10:25:03     INFO -  >>>>>>>
10:25:03     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
10:25:03     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
10:25:03     INFO -  running event loop
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
10:25:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting reset_predictor
10:25:03     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (3)
10:25:03     INFO -  (xpcshell/head.js) | test reset_predictor finished (3)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting test_link_hover
10:25:03     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
10:25:03     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_link_hover - [test_link_hover : 76] true == true
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (3)
10:25:03     INFO -  (xpcshell/head.js) | test test_link_hover finished (3)
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
10:25:03     INFO -  netwerk/test/unit/test_predictor.js | Starting test_pageload
10:25:03     INFO -  (xpcshell/head.js) | test test_pageload pending (2)
10:25:03     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_pageload - [test_pageload : 140] 0 == 0
10:25:03     INFO -  (xpcshell/head.js) | test run_next_test 2 finished (2)
10:25:03     INFO -  <<<<<<<
10:25:03     INFO -  TEST-START | netwerk/test/unit_ipc/test_predictor_wrap.js
10:30:03  WARNING -  TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit_ipc/test_predictor_wrap.js | Test timed out
10:30:03     INFO -  TEST-INFO took 300061ms
10:30:03     INFO -  >>>>>>>
10:30:03     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
10:30:03     INFO -  (xpcshell/head.js) | test pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
10:30:03     INFO -  running event loop
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (info) [JavaScript Warning: "ReferenceError: assignment to undeclared variable _XPCSHELL_PROCESS" {file: "/builds/slave/test/build/tests/xpcshell/head.js" line: 1212}]"
10:30:03     INFO -  PROCESS | 1808 | Xlib:  extension "RANDR" missing on display ":0".
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test finished (2)
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting reset_predictor
10:30:03     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test reset_predictor finished (2)
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_link_hover
10:30:03     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
10:30:03     INFO -  TEST-PASS | netwerk/test/unit_ipc/test_predictor_wrap.js | verifier_maybe_run_next_test - [verifier_maybe_run_next_test : 76] true == true
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test test_link_hover finished (2)
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_pageload
10:30:03     INFO -  (xpcshell/head.js) | test test_pageload pending (2)
10:30:03     INFO -  TEST-PASS | netwerk/test/unit_ipc/test_predictor_wrap.js | test_pageload - [test_pageload : 140] 0 == 0
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 2 finished (2)
10:30:03     INFO -  <<<<<<<
10:30:03     INFO -  xpcshell return code: None
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Process still running after test!
10:30:03     INFO -  >>>>>>>
10:30:03     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
10:30:03     INFO -  (xpcshell/head.js) | test pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
10:30:03     INFO -  running event loop
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
10:30:03     INFO -  "CONSOLE_MESSAGE: (info) [JavaScript Warning: "ReferenceError: assignment to undeclared variable _XPCSHELL_PROCESS" {file: "/builds/slave/test/build/tests/xpcshell/head.js" line: 1212}]"
10:30:03     INFO -  PROCESS | 1808 | Xlib:  extension "RANDR" missing on display ":0".
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test finished (2)
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting reset_predictor
10:30:03     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test reset_predictor finished (2)
10:30:03     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_link_hover
10:30:03     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
10:30:03     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
See Also: → 1178052
See Also: 1178052
Apparently the prefs need to be set before creating the predictor.

The pref causing problems was that thunderbird has
pref("browser.cache.use_new_backend_temp",  false);

The test tries sets it to true, but too late.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8634922 - Flags: review?(hurley)
Duplicate of this bug: 1176613
Hrm, the patch looks ok (though I'd like to get rid of the added comment - the information there isn't particularly useful), but this makes me ask the question - does thunderbird use the new cache? (Does it use an HTTP cache at all?) If not, then the better course of action would be to disable the predictor and its tests on comm-central. (That may be a better course of action no matter what - I don't see the predictor being particularly useful for a mail client.)
Attachment #8634922 - Flags: review?(hurley)
Thunderbird still uses the old cache, though we want(need) to migrate - see bug 1021843.
While probably not important, extensions do a lot of stuff... and we can't really realistically pick and choose features much.

Anyway, the test doesn't work as is. It's setting the prefs too late. I don't want to disable tests that could just be fixed.
Attachment #8635511 - Flags: review?(hurley)
Attachment #8634922 - Attachment is obsolete: true
Comment on attachment 8635511 [details] [diff] [review]
bug1176612_test_predictor.patch

Review of attachment 8635511 [details] [diff] [review]:
-----------------------------------------------------------------

Again, I think the better tactic here (for comm-central) is to just disable the predictor entirely - it will provide (at best!) little to no benefit in a non-browsing scenario, and is more likely to just take up space in the disk cache that would be better used serving other components. I'm r+ing this to clear up the intermittent failures, but also highly suggest a comm-central patch to disable the predictor (and its test).
Attachment #8635511 - Flags: review?(hurley) → review+