test_addons_engine.js is going to permafail when Gecko 41 merges to Beta

VERIFIED DUPLICATE of bug 1176638

Status

Cloud Services
Firefox Sync: Backend
--
major
VERIFIED DUPLICATE of bug 1176638
3 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Any ideas what might be going on here, Mark?

https://treeherder.mozilla.org/logviewer.html#?job_id=8742656&repo=try

10:52:24 INFO - running event loop
10:52:24 INFO - services/sync/tests/unit/test_addons_engine.js | Starting test_addon_install
10:52:24 INFO - (xpcshell/head.js) | test test_addon_install pending (2)
10:52:24 INFO - PROCESS | 4887 | Ensure basic add-on APIs work as expected.
10:52:24 INFO - PROCESS | 4887 | 1434736344857 addons.xpi WARN Invalid XPI: signature is required but missing
10:52:24 INFO - PROCESS | 4887 | 1434736344857 addons.xpi WARN Invalid XPI: signature is required but missing
10:52:24 INFO - TEST-PASS | services/sync/tests/unit/test_addons_engine.js | test_addon_install - [test_addon_install : 49] [object Object] != null
10:52:24 WARNING - TEST-UNEXPECTED-FAIL | services/sync/tests/unit/test_addons_engine.js | test_addon_install - [test_addon_install : 50] null == "extension"
10:52:24 INFO - /builds/slave/test/build/tests/xpcshell/tests/services/sync/tests/unit/test_addons_engine.js:test_addon_install:50
10:52:24 INFO - /builds/slave/test/build/tests/xpcshell/head.js:_run_next_test:1467
10:52:24 INFO - /builds/slave/test/build/tests/xpcshell/head.js:do_execute_soon/<.run:653
10:52:24 INFO - /builds/slave/test/build/tests/xpcshell/head.js:_do_main:207
10:52:24 INFO - /builds/slave/test/build/tests/xpcshell/head.js:_execute_test:513
Flags: needinfo?(markh)
The problem is almost certainly going to be the lines "Invalid XPI: signature is required but missing" - the addon we use for the test is not signed. Bug 1132995 seems to be tracking this.
Depends on: 1132995
Flags: needinfo?(markh)
(Reporter)

Comment 2

3 years ago
Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1132995
Resolution: --- → DUPLICATE
Duplicate of bug: 1176638
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.