Status bar is white when it should be coloured

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Status bar, Utility tray, Notification
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cwiiis, Assigned: cwiiis)

Tracking

({polish, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The status bar is now white for the communications apps (Phone, SMS, Contacts), Calendar and Music, when it should be their respective colours of green, orange and black. E-mail is apparently unaffected.
I can't reliably reproduce this bug. I saw it once in maybe 30 attempts. I saw a black status bar in Messages app once as well. Obviously we can't find a window for a bug that's not reliably reproducible. Changing tag to steps-wanted, unless the reporter can provide steps that reliably reproduces the bug.

Tested on:
Device: Flame (KK, full flashed, 319MB/512MB memory)
BuildID: 20150622010206
Gaia: d8bac9577a537b5e6bafc3f7ed088af5ea60c99e
Gecko: a38c23ccca0a
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted → steps-wanted
Chris what build are you using?  This seems very similar to bug 1175160.
Flags: needinfo?(jmercado) → needinfo?(chrislord.net)
(Assignee)

Comment 3

3 years ago
Clearing my needinfo, but this bug still exists in a less extreme way than it did when I reported it.

Taking, because I'm fairly certain why it happens and I'm looking at a fix now because it was bugging me...

STR:

1. Install Facebook
2. Launch Facebook (may require you to have previously logged in)

Expected:

Statusbar is blue, rocketbar has the Facebook favicon

Actual:

Statusbar is often white, with no favicon. Refreshing usually fixes it.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
Keywords: steps-wanted → polish
(Assignee)

Comment 4

3 years ago
Heh, looks like Facebook have removed (or changed?) the meta tag, but I can reproduce this in my own apps and have a fix.
Created attachment 8635234 [details] [review]
[gaia] Cwiiis:bug1176726-statusbar-wrong-color > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8635234 [details] [review]
[gaia] Cwiiis:bug1176726-statusbar-wrong-color > mozilla-b2g:master

There are so many bugs/races because we don't load AppChrome synchronously, and it just looks bad when it pops in suddenly... I wish we just loaded it synchronously and sucked up that it might not perform quite as well...

Either way, this is a fix that doesn't do that.
Attachment #8635234 - Flags: review?(etienne)
(Assignee)

Updated

3 years ago
Blocks: 994858
Comment on attachment 8635234 [details] [review]
[gaia] Cwiiis:bug1176726-statusbar-wrong-color > mozilla-b2g:master

r=me with
* a cleanup of |this.metaChangeDetail| in |destroyBrowser|
* a simple unit test similar to the 'Load event before _opened' one
Attachment #8635234 - Flags: review?(etienne) → review+
(Assignee)

Comment 8

3 years ago
Test added, merged: https://github.com/mozilla-b2g/gaia/commit/c70fa22eb54d3c0f5c03d75d51d4a2a1a421d94a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.