Unable to send emails in v38.01 - nothing happens, no error messages.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: eddie, Unassigned)

Tracking

({regression})

38 Branch
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB38?])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

v38.0.1 installed automatically.  After that, when I try to send a message, nothing happens.  No error messgaes.  I have two PCs, both had updated to v38.01.  Both fail to send emails.  Both are running Win7 Pro (with SP1).


Actual results:

Tried to send an email.  Nothing happened.  No error messages, no progress bar, nothing.


Expected results:

The email should have been sent.
Probably bug 1174159? Does setting  network.auth.force-generic-ntlm-v1 true help?
Keywords: regression
(In reply to Magnus Melin from comment #1)
> Probably bug 1174159? Does setting  network.auth.force-generic-ntlm-v1 true
> help?
Flags: needinfo?(eddie)

Comment 3

4 years ago
Potentially Noteworthy: I have this problem and have multiple accounts including different smtp servers. The problematic ones are all Google's servers. If I select a non google "send from" address that has a currently working smtp, then without doing anything else, reselect the Google smtp, I can now send the email via Google (gmail). The problematic smtp is my Default smtp:
smtp.gmail.com
port 465
Normal password
SSL/TLS

Comment 4

4 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> (In reply to Magnus Melin from comment #1)
> > Probably bug 1174159? Does setting  network.auth.force-generic-ntlm-v1 true
> > help?

I changed this setting in the config, restarted TB and nothing changed. The problem still continues.

Updated

4 years ago
Whiteboard: [regression:TB38?]

Comment 5

4 years ago
I now have at least 2 PC that are updated to 38.1.0 and no longer able to send email.  Here is what I get when try to send email.

"Sending of the message failed.
The message could not be sent using Outgoing server (SMTP) mail.server.com for an unknown reason. Please verify that your Outgoing server (SMTP) settings are correct and try again."
Does comment 1 help? If not, file a new bug with details, like an smtp protocol log https://wiki.mozilla.org/MailNews:Logging

Comment 7

4 years ago
Same here.  Tried Comcast and GMail.  38.0 worked.  38.1 doesn.t  No error message.  Just nothing happens.  Opening the drop menu for the Send button reveals an empty menu.

Comment 8

4 years ago
(In reply to joe_dame from comment #5)
> I now have at least 2 PC that are updated to 38.1.0 and no longer able to
> send email.  Here is what I get when try to send email.
> 
> "Sending of the message failed.
> The message could not be sent using Outgoing server (SMTP) mail.server.com
> for an unknown reason. Please verify that your Outgoing server (SMTP)
> settings are correct and try again."

Ok, if I disabled using authentication for outgoing then I am able to sent email.  But, this is not going to work because I don't want to open our mail server up to allow relaying email without authentication from outside.  Please, fix this issue.

Comment 9

4 years ago
Well, here is a weird one for you. Today I followed the Comment #6 instructions and set up a POP log file (because I goofed and forgot to change to SMTP). When I ran as admin, TB worked wonderfully and the problem wasn't there. Thinking this might be a permission issue, I decided to open TB without the batch file and do a sanity check. Sure enough, the problem is gone - It is working now. The only thing I can think of is that there were several big MS Windows updates in the past two weeks that I installed today. 

Noteworthy, this looks like it was fixed in a TB update as well but perhaps required a Windows update?:
https://bugzilla.mozilla.org/show_bug.cgi?id=1176773

Comment 10

4 years ago
Typo!!! I meant to say Windows REBOOT below:
>this looks like it was fixed in a TB update as well but perhaps
> required a Windows update?
(In reply to Amy C from comment #9)
> Well, here is a weird one for you. Today I followed the Comment #6
> instructions and set up a POP log file (because I goofed and forgot to
> change to SMTP). When I ran as admin, TB worked wonderfully and the problem
> wasn't there. Thinking this might be a permission issue, I decided to open
> TB without the batch file and do a sanity check. Sure enough, the problem is
> gone - It is working now. The only thing I can think of is that there were
> several big MS Windows updates in the past two weeks that I installed today. 
> 
> Noteworthy, this looks like it was fixed in a TB update as well but perhaps
> required a Windows update?:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1176773
(In reply to joe_dame from comment #8)
> (In reply to joe_dame from comment #5)
> > I now have at least 2 PC that are updated to 38.1.0 and no longer able to
> > send email.  Here is what I get when try to send email.
> > 
> > "Sending of the message failed.
> > The message could not be sent using Outgoing server (SMTP) mail.server.com
> > for an unknown reason. Please verify that your Outgoing server (SMTP)
> > settings are correct and try again."
> 
> Ok, if I disabled using authentication for outgoing then I am able to sent
> email.  But, this is not going to work because I don't want to open our mail
> server up to allow relaying email without authentication from outside. 
> Please, fix this issue.

NTLMv1 is insecure, so Thunderbird behavior is not going to be changed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(eddie)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.