problem switching between multiple accounts in folder pane and between calendar/folder view - screen is not refreshing/responding to context change.

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: mitchkuperman, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

Simply switching context from one mail account to another in folder pane.


Actual results:

Context does not change from one inbox to the other.


Expected results:

When clicking from one inbox to another inbox in the folder pane, the folder contents should refresh to the contents of the selected inbox. Ever since applying the most recent build (38.0.1) this has been an issue. I click an alternate mailbox and there is no change. Then if I mouse over the messages pane, the correct contents appear as the mouse passes over it...line by line. This is very odd behavior that coincided with application of the latest update, which is also the first time I ever recall being prompted to reboot the whole PC to apply it. All previous updates only required restarting Thunderbird. I have no idea if this is how it was designed to work.
(Reporter)

Comment 1

3 years ago
Possible cause/solution: After submitting this report I tried manually compacting all inbox folders and have not seen this issue recurring as of yet.

Comment 2

3 years ago
odd. How big are the folders?
Component: Mail Window Front End → Folder and Message Lists
Flags: needinfo?(mitchkuperman)
Summary: problem switching between multiple accounts in folder pane → problem switching between multiple accounts in folder pane. resolved by compact
(Reporter)

Comment 3

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> odd. How big are the folders?

Thanks for looking at this. I've been keeping my main inbox well trimmed lately, but that is a likely suspect (see comment I added a short time ago). I ran a compact on that folder manually and it said close to 14MB was recovered! That surprised me since I though they automatically compacted at some interval. I will keep an eye on the functioning for any further occurrence, but so far, that may have been the cause.
Flags: needinfo?(mitchkuperman)
(Reporter)

Comment 4

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> odd. How big are the folders?
Wayne, I am still seeing that issue happening...mostly with my primary email account folder. It is currently at 48 messages and about 1.7 MB. I have 3 other accounts below it in the folder pane. When I switch to one of those, then back to my primary inbox, there is no change until I mouse over the message pane and the messages magically reappear. I have compacted over and over and even tried the 'repair folder' option in properties. Could there be damage to the code somewhere? TIA
(Reporter)

Comment 5

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> odd. How big are the folders?
This is the first time I'm using this reporting facility, so I don't know if I did something wrong, but I attempted to have a conversation about this issue with no further replies. In the absence of any suggestions, I elected to uninstall the application and do a clean install with the latest downloaded build, then I restored all of my accounts, mail, settings, etc., from a recent backup. So far, I am not seeing this issue recurring. All I can say is that the installation I was using was installed a long time ago and went through many automatic updates, so there is the possibility that something got out of whack over time, although it DID begin with the last automatic update. Good thing I'm a 34-year IT veteran and could find a way to deal with this with no outside help!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(mitchkuperman)
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> odd. How big are the folders?
Wayne, don't know if I'm using this right, but this issue is NOT fixed, started with 38.0.1. It is intermittent, but happens more often than not. When attempting to switch from one mail account to another in the folder pane OR attempting to switch from calendar view to folder view (or vice versa) the screen DOES NOT respond....the screen will change to what SHOULD be displayed there only as the mouse pointer is moved over it. I completely uninstalled, then reinstalled directly from the download link, restored my data from a backup and this did not solve the issue! I'm all thumbs with this reporting facility so I don't even know if anyone is seeing this! HELP!!!
Flags: needinfo?(mitchkuperman)
Summary: problem switching between multiple accounts in folder pane. resolved by compact → problem switching between multiple accounts in folder pane and between calendar/folder view - screen is not refreshing/responding to context change.

Comment 7

3 years ago
Does it happen in version 38.3.0?
Does it happen if you are started in safe mode?
  see https://support.mozilla.org/en-US/kb/safe-mode
Flags: needinfo?(mitchkuperman)
(Reporter)

Comment 8

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #7)
> Does it happen in version 38.3.0?
> Does it happen if you are started in safe mode?
>   see https://support.mozilla.org/en-US/kb/safe-mode

Wayne,
In response to your questions, after applying the 38.3.0 update I have not seen any reoccurrence of this issue. An update prior to that had not solved the problem at all. I hadn't tried the safe-mode test as it was no longer necessary. I know that's very general information but I hope it helps you narrow down what was causing that to happen.
Flags: needinfo?(mitchkuperman)

Comment 9

3 years ago
thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME

Comment 10

3 years ago
Happens to me too:
1st case: Thunderbird nightly: 45.0a1
2nd case: Thunderbird beta:    42.0b2

Both show the very same behavior: switching between different Mail cases to update mail-body-panel. Nothing is shown in this part of the windows until thunderbird is restarted again. You may further switch to different mail, but the mail-body-pane keeps displaying nothing.
Selecting a mail, then going to "View -> Mail Source" will show the source of the mail selected.

Comment 11

3 years ago
Created attachment 8692497 [details]
NC158V3_138_Status report from osoz01-muc.bfs.de - Inbox - tschweikle@bfs.de - Daily.jpg

Mail-Body-Pane empty after switching between about 20 Mail.

Comment 12

3 years ago
Created attachment 8692498 [details]
NC158V3_139_Source of_ imap___TSchweikle@mail-muc.bfs.de_993_fetch_3EUID_3E_INBOX_3E285010 - Daily.jpg

Mail source shows: mail has a body, but it is just not displayed.

Comment 13

2 years ago
Thomas, 
If your problem occurs with Thunderbird started in safe mode then please file a new bug. Your issue will get lost here in a closed bug.
https://support.mozilla.org/en-US/kb/safe-mode
You need to log in before you can comment on or make changes to this bug.