[spark] Can't answer calls without unlocking phone and entering my PIN

RESOLVED WONTFIX

Status

Firefox OS
Gaia
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: callahad, Unassigned)

Tracking

({DevAdvocacy, foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spark])

(Reporter)

Description

3 years ago
I'm not sure exactly how I got into this state, but I recently attempted to answer a call but instead of answer or rejecting it... I somehow dismissed the call screen.

At which point my phone kept loudly ringing, but I was stuck on my lockscreen.

Before I could answer the call, I had to:

1. Swipe to unlock
2. Enter my PIN
3. Wait for the homescreen to load
4. Pull down the notification drawer
5. Tap on "Show Call Screen"

Only then could I finally actually answer the call.

This shouldn't be possible.

Potentially related to Bug 1175338
QAwanted : please investigate and verify.  If this still occurs please nom for 2.5
Keywords: qawanted
QA Whiteboard: [foxfood-triage]
Keywords: foxfood
Keywords: dogfood
I was not able to reproduce this issue on the latest Aries spark build.

Actual Results: The user can answer the call from the lock screen without entering a passcode.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150731163020
Gaia: 8502d07cd7e68da79303471acf64eea48b3dce24
Gecko: ca53d4297f02
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
I was unable to reproduce this bug on the latest Aries build.  I attempted various methods of answering a phone call such as:

-Using the STR listed in comment 0. 
-Locking/unlocking the screen then answering the call, etc. 
-Tapping home button while receiving a call, then navigating back to call screen after passcode is entered. 

Actual Results:  
The user is able to answer the call as intended (and without by-passing the passcode). 

Repro Attempts: 0/20

Environmental Variables:
Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Leaving qawanted tag for another tester to try.
I may have reproduced this issue, but I don't believe it is actually a bug.  If the user taps the home button when receiving a call on a locked phone, they will dismiss the call screen and be shown the lockscreen, which seems to be the state that the bug reporter found themself in.

However, there is a banner up at the top of the screen indicating the incoming call, which can be tapped to bring the user back to the callscreen without unlocking the device. This banner does not dismiss over time, and may be tapped as long as the phone continues to ring.

This behavior is identical on both Flame and Spark builds.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5
Build ID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [foxfood-triage] → [QAnalyst-Triage?][foxfood-triage]
Flags: needinfo?(ktucker)
QA Contact: mshuman
Can you confirm that you tapped the software home button here as stated in Comment 4.
Flags: needinfo?(dan.callahan)
(Reporter)

Comment 6

3 years ago
I haven't seen this on more recent builds, but I'm fairly certain that I did not hit the home button, nor was there a banner at the top of the lock screen that would take me to the call.

Happy to mark this as resolved by more recent builds.
Flags: needinfo?(ktucker)
Flags: needinfo?(dan.callahan)
I have been unable to reproduce this issue on latest Aries and Flame. Incoming calls can be answered/rejected on top of passcode protected lockscreen.

Removing qawanted due to inability to reproduce the issue by multiple parties including reporter.

Not reproducible on:
Device: Aries 2.5
BuildID: 20150909131219
Gaia: 60e212543329ee48f2921e0cd92aaca4b4ce2f6a
Gecko: dd9e40b4695909f1595814c0e79e4d55d73dc283
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150909030221
Gaia: e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Gecko: 01ae99b53561a2c3b40533d8c1c92bd3efc42d00
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][foxfood-triage] → [QAnalyst-Triage+][foxfood-triage]
Flags: needinfo?(jmercado)
Doesn't seems to occur since un-reproducible
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.